Results 1 to 13 of 13

Thread: '87 K75s speedometer problems

  1. #1
    Club President
    Join Date
    Mar 2004
    Location
    Buffalo NY
    Posts
    16

    '87 K75s speedometer problems

    I have bought a few used speedometers in an attempt to fix the speedometer/instrument gauges on a 1987 K75s, none work now. What years would fit a 1987 K75s? 1984 to what year gauges? Next step is to send one off to one of the two better known shops for a repair. thanks

  2. #2
    Mars needs women! 35634's Avatar
    Join Date
    Apr 2008
    Location
    SW Ohio
    Posts
    2,012
    If you have a few try fixing one yourself. I still have the original on mine, though the connections have been cleaned and several gears replaced. Lots of info on repairing them.
    1987 K75S
    Original litter
    Original owner
    2012 Ural Gear Up

  3. #3
    3 Red Bricks
    Join Date
    Jan 2007
    Location
    Pleasanton, Ca.
    Posts
    3,341
    Quote Originally Posted by Jbuffalo View Post
    I have bought a few used speedometers in an attempt to fix the speedometer/instrument gauges on a 1987 K75s, none work now. What years would fit a 1987 K75s? 1984 to what year gauges? Next step is to send one off to one of the two better known shops for a repair. thanks
    You want a cluster that has a gas pump symbol next to the right hand light at the bottom of the speedo but not next to the left light ('86 and later).

    You do not want the clusters that have several white horizontal lines across the bottom of the gauges (4valve bikes).

    I believe all others will work on a non ABS bike (86-95). ABS bikes need clusters wired for ABS.


    Are you getting NO speedo now? I thought you were getting double readings.


    Try removing the speed sensor from the final drive. Take a soldering gun or iron and hold it (turned on) within 1/4" of the end of the sensor (DON'T LET IT TOUCH). Withthe key and kill switch on, the 60 cycles from the AC current should cause your speedo to read 45 mph if everything is working.




    LONG MAY YOUR BRICK FLY!

    Ride Safe, Ride Far, Ride Often

    Lee Fulton Forum Moderator
    3 Marakesh Red K75Ss
    Mine, Hers, Spare

  4. #4
    Club President
    Join Date
    Mar 2004
    Location
    Buffalo NY
    Posts
    16

    K75s speedometer update

    After much time and effort I had it fixed but the mileage indicator did not work and a small male tab broke off from the main connector(the one with all the pins on the back of the speedometer) as I took it on and off the bike for testing-it looks like it was damaged before. . I tried to put it back but was unable to do so and destroyed that part. . I can try to put all three of the broken instruments together-long shot , buy a used one or send it to a repair shop. No sure what I will do.

  5. #5
    3 Red Bricks
    Join Date
    Jan 2007
    Location
    Pleasanton, Ca.
    Posts
    3,341
    Probably cheaper to buy a good used one off ebay.



    LONG MAY YOUR BRICK FLY!

    Ride Safe, Ride Far, Ride Often

    Lee Fulton Forum Moderator
    3 Marakesh Red K75Ss
    Mine, Hers, Spare

  6. #6
    Club President
    Join Date
    Mar 2004
    Location
    Buffalo NY
    Posts
    16

    K75s update

    Thanks for the comments-there aren't too many places you can discuss and cuss a K speedometer unit. I am trying to put a good one together.

  7. #7
    Mars needs women! 35634's Avatar
    Join Date
    Apr 2008
    Location
    SW Ohio
    Posts
    2,012
    This might be worth checking out, link to a shop that works on K speedos... http://www.motobrick.com/index.php?t...97.0;topicseen
    1987 K75S
    Original litter
    Original owner
    2012 Ural Gear Up

  8. #8
    Club President
    Join Date
    Mar 2004
    Location
    Buffalo NY
    Posts
    16

    K75s speedometer unit

    I notice that some of the used ones on ebay have an extra male pin on the back. My plugs that go into the back of the instrument unit have on both sides 4 pins then a space? Is that an Abs unit, can they be used? thanks

  9. #9
    Club President
    Join Date
    Mar 2004
    Location
    Buffalo NY
    Posts
    16

    K75s speedometer

    That test with the soldering gun works great. I have found one speedometer unit that works now I have to put together a whole instrument unit-thanks

  10. #10
    Club President
    Join Date
    Mar 2004
    Location
    Buffalo NY
    Posts
    16

    K75s instrument problems-speedometer

    Thanks for the help I now have a working speedometer and tachometer and most of the lights in the instrument pod. Question, all the lights should come on when the key is turned on- right? I am not getting the coolant light or any of the two fuel lights. Should they come on. thanks

  11. #11
    3 Red Bricks
    Join Date
    Jan 2007
    Location
    Pleasanton, Ca.
    Posts
    3,341
    The early K bikes do not have an instrument bulb check function.

    When you turn on the key, you get a status display.

    No oil pressure (because the engine isn't running) = oil light on

    No charging (because the engine isn't running). = charging light on

    Engine not overtemp = temp light OFF

    Fuel not low = right hand low fuel light OFF

    Left hand low fuel light used only on '85 and earlier K100s. If there is a gas symbol next to each gas light, the cluster/speedometer is out of one of those bikes. That light was used as an ABS light on later bikes.

    Choke light (switch and bulb eliminated on later models maybe around '92) on or off depending on position of lever.



    Your lights are working correctly.




    LONG MAY YOUR BRICK FLY!

    Ride Safe, Ride Far, Ride Often

    Lee Fulton Forum Moderator
    3 Marakesh Red K75Ss
    Mine, Hers, Spare

  12. #12
    Club President
    Join Date
    Mar 2004
    Location
    Buffalo NY
    Posts
    16

    K75s Speedo problems etc

    Thank you I can put the instrument pod back on-- install the fairing. ..and ride it. --

  13. #13
    3 Red Bricks
    Join Date
    Jan 2007
    Location
    Pleasanton, Ca.
    Posts
    3,341
    Make sure ALL the illumination (green) bulbs are working BEFORE you put it back in.



    LONG MAY YOUR BRICK FLY!

    Ride Safe, Ride Far, Ride Often

    Lee Fulton Forum Moderator
    3 Marakesh Red K75Ss
    Mine, Hers, Spare

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •