Results 1 to 5 of 5

Thread: 98 R1100RT Sticking front brake lever

  1. #1
    Registered User rtwoody's Avatar
    Join Date
    Jan 2011
    Location
    The Hammer
    Posts
    13

    98 R1100RT Sticking front brake lever

    Hi All looking for a suggestion, advice on this issue the front brake lever is not fully returning to position when released and as such the brake lights are staying on. I've tried lubricating the pivot point but it still seems sticky, do I need to disassemble the unit to clean properly?
    Thanks in advance for any suggestion
    Rod
    Roderick Wood
    Hamilton Ontario
    '98 R1100RT,81 Honda CB750K

  2. #2
    Registered User
    Join Date
    Apr 2006
    Location
    maine
    Posts
    190
    I have the same model and year. Last fall I had the exact same problem. I ended up having to rebuild the front master cylinder with a rebuild kit from beemer boneyard. Has worked properly since.

    Mark

  3. #3
    Registered User
    Join Date
    Apr 2012
    Location
    Los Angeles, CA
    Posts
    346
    Sounds more like a pressure problem than a lever problem. Master cylinder, as Mark notes, or caliper seals, or failing hoses, or pads near end-of-life....
    2000 R1100RT / 1987 K75C (RIP) / Santa Clarita, CA

  4. #4
    Benchwrenching PGlaves's Avatar
    Join Date
    Oct 2003
    Location
    "Big Bend" TX
    Posts
    8,788
    I stumbled on a case, helping a rider sort out an always-on brake light at the recent rally in Nakusp. Digging a little deeper than just cleaning/lubing the lever, he discovered that a little rubber boot or seal where the lever contacts the piston rod had deteriorated and was in the way, preventing full lever return.

    This is precisely the type of issue I might expect to encounter on a 15 year old bike.
    Paul Glaves - "Big Bend", Texas U.S.A
    "The greatest challenge to any thinker is stating the problem in a way that will allow a solution." - Bertrand Russell
    http://www.bigbend.net/users/glaves

  5. #5
    Registered User rtwoody's Avatar
    Join Date
    Jan 2011
    Location
    The Hammer
    Posts
    13
    Update I took the lever apart at the pivot bolt and found the plastic roller sticking cleaned everything up and re-assembled and its working properly again.
    once again thanks for the help and suggestions
    Roderick Wood
    Hamilton Ontario
    '98 R1100RT,81 Honda CB750K

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •