Results 1 to 5 of 5

Thread: Brake failure light '07 RT

  1. #1
    Registered User
    Join Date
    Feb 2012
    Location
    Deltaville, VA
    Posts
    21

    Brake failure light '07 RT

    We'll I have the brake failure light. No ABS. I have some questions. Has semper fi done any tech tips on this? Are people having good luck recently with module master? What special tools will I have to have to remove the abs modulator? and then to bleed brakes? Do I have to have the Fault computer? And last has anyone just used the bike as a non-abs bike? Thanks
    Whit Perry, 07' 1200RT
    179780
    "The simple things, the true things, the silent men who do things" - Robert Service

  2. #2
    A bozo on the bus deilenberger's Avatar
    Join Date
    Mar 2003
    Location
    Spring Lake NJ, USA
    Posts
    7,633
    Quote Originally Posted by wudshp View Post
    We'll I have the brake failure light. No ABS. I have some questions. Has semper fi done any tech tips on this? Are people having good luck recently with module master? What special tools will I have to have to remove the abs modulator? and then to bleed brakes? Do I have to have the Fault computer? And last has anyone just used the bike as a non-abs bike? Thanks
    Whit,

    Hint - it's LOTS easier to answer a string of questions if they're put into separate paragraphs.

    This is my answers without paragraphs: No. Yes. None really. GS911 would be nice. Nor necessarily, but if you want to activate the ABS bleed, yes, it would be useful - can be done with the GS911. Not that I know of.

    There'ya go..
    Don Eilenberger http://www.eilenberger.net
    Spring Lk Heights NJ NJ Shore BMW Riders New Sweden BMW Riders
    '07 R1200R (current ride) and some bimmers.. and a Porsche

  3. #3
    Registered User
    Join Date
    Nov 2009
    Posts
    11

    What was your fix

    My brake failure light comes on after 125 mile ride .......Happened twice now.......If I shut bike down and restart its fine for about the first 100 miles...What was your fix? I also have an 07 RT......

  4. #4
    Registered User
    Join Date
    Aug 2004
    Location
    SW Ohio
    Posts
    153
    Check simple stuff first, such as a chafed wire running to the abs sensor. Not an uncommon problem.
    Good luck.
    2007 R1200RT
    2000 R1100rt sold @ 72,000
    Iron Butt #24605

  5. #5
    Addicted to curves azgman's Avatar
    Join Date
    Jun 2003
    Location
    AZ
    Posts
    674
    Take a hammer and whack the back of the abs motor a couple of times. That should reseat the motor brushes. In time you will need to have the abs unit rebuilt or replaced, but the hammer trick will work for some time.
    MOA #107139
    RA #28511
    YB #2005

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •