Results 1 to 3 of 3

Thread: oil weepage around oil pressure sensor

  1. #1
    aapasquale
    Join Date
    Aug 2011
    Location
    Sag Harbor, New York
    Posts
    128

    oil weepage around oil pressure sensor

    over the last three weeks or so have noticed a very small oil leak. Doesn't amount to more than a few drops every 3-4 days. I would still like to clear it up. i washed the bike last week to see if I could pinpoint the leak location. It is from the sensor area. The sensor is functioning properly and is tight. Is it possible for something inside the sensor to separate allowing miniscule oil leakage? I've been told that using a high temperature sealant (Permatex) around the last few threads might take care of it. Possible? I looked up the OEM sensor and it's only $16. It might be best to buy a new sensor and go with that. Any thoughts?
    Thanks
    Tony

  2. #2
    Registered User dieselyoda's Avatar
    Join Date
    Mar 2013
    Location
    Winnipeg, MB, Canada
    Posts
    397
    In my case, the porcelain on the sensor itself was leaking. Get one for a BMW 325i with the E36 engine. Local parts stores have them.
    1997 R1100RT (Restored Basket Case) , 1981 KZ 440 LTD (Restored Basket Case)
    1986 K75S(the beutch), 1993 K1100RS (blown engine), 1997 Chev Short Box (4x4 with an LT1)
    "Life isn't about how fast or how high, it's about how well you bounce."

  3. #3
    aapasquale
    Join Date
    Aug 2011
    Location
    Sag Harbor, New York
    Posts
    128
    Quote Originally Posted by Dieselyoda View Post
    In my case, the porcelain on the sensor itself was leaking. Get one for a BMW 325i with the E36 engine. Local parts stores have them.
    Thanks-I believe my leakage is from the same cause

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •