Results 1 to 3 of 3

Thread: 2003 F650GS Dakar Speedometer

  1. #1
    Registered User
    Join Date
    Aug 2009
    Posts
    259

    2003 F650GS Dakar Speedometer

    Yesterday, my speedometer stuck at 30 mph. It quivers a little from time to time, sometimes moves a little, like down to 20 mph, or up to 35 mph, but the needle remains in the same position when moving or stopped.

    I disconnected the battery and the needle stayed in the same position. Odometer still works and appears to be accurate.

    Has anyone else had this happen? If so, what was the outcome? Can the speedometer be replaced separately, or does the entire instrument cluster need to be replaced? Entire instrument cluster is for sale on ebay used for $155. Has anyone been able to fix the speedometer? The bike has about 16,500 miles and will be due for 18,000 mile service soon.

    My bike has ABS and I have heard that my speedometer is driven by the ABS sensor on the rear wheel. Others have reported speedometer problems that were fixed by cleaning the rear ABS sensor. I assume that since the needle does not return to zero when I disconnect the battery and the odometer is working accurately, that the problem must be isolated to the speedometer itself. Is that a good assumption?

    Thanks in advance for any help or advise on the best way go about getting this to work again.
    Glenn
    2003 F650GS Dakar

  2. #2
    Registered User
    Join Date
    Aug 2009
    Posts
    259
    To my great surprise, the speedometer started working again this morning.

    It stuck at around 11 am last Saturday, I did not ride on Sunday or Monday, and today it started working.

    It appears to be accurate. The only thing that *may* be unusual is that when decelerating, the needle appears to very slightly step down to zero in tiny steps. I say *may* because it could be that it always did this and I just didn't notice it before.

    The only thing unusual about today is that it was cool this morning when I left, about 62 F.

    Still interested if anyone else has had this issue. I have read reports elsewhere on the internet of similar symptoms, but no one has reported what they did to fix the problem.
    Glenn
    2003 F650GS Dakar

  3. #3
    Registered User
    Join Date
    Oct 2005
    Location
    NW PA
    Posts
    129
    The first thing to do is make sure the battery connection are TIGHT. Loose connections are not uncommon on the F650s and cause all sorts of strange problems.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •