Results 1 to 4 of 4

Thread: ABS test of modulator out of the bike?

  1. #1
    Nickname: Droid
    Join Date
    Jun 2005
    Location
    Green Bay, WI
    Posts
    2,352

    ABS test of modulator out of the bike?

    Just had a thought, being as I have an extra ABS modulator for my 94 R1100RS. I replaced it back in 06 with a modulator from a K1100RS. Everything mounted up fine, bleed out easily, and my local dealer "initialized" the K1100RS ABS to my R1100RS. Been working great since 06.

    Now I wonder if there is a service shop that can test the original ABS modulator from my RS even if it's not installed in the bike?

    I was told by another dealer back in 98 that it was "fried" because they could not clear the fault code that was "burned in" because I did too many low-voltage/cold-starts over the many cool seasons here in Wisconsin. At that time I just pulled the ABS relay to turn off the blinking lights. I rode the bike for another eight years w/o ABS, and four of those years were on the same battery the dealer said I should replace.
    One thing that did happen back in 98 was a crash that had the bike running, ignition on, laying on it's side, for a mintues after I fell off the bike. I wonder if that scenario had more to do with the fault code issue than the cold starting problem common to the early ABS system.

  2. #2
    MOA #24991 Pauls1150's Avatar
    Join Date
    Apr 2008
    Location
    south of Los Angeles
    Posts
    1,533
    Don't have a real answer for you, but...
    Having worked in aerospace electronics for most of my life, I find it difficult to accept that a fault code could be "burned in" to your unit as the dealer suggests. PROMs (Programmable Read-Only Memory) and FPGAs (Field-Programmable Gate Array) require specific voltages applied to specific pins to set up their initial states. This is typically done in dedicated (but adaptable) fixtures. These ICs can get narfed, though.
    Maybe that modulator-rebuild outfit (discussed elsewhere in this forum) can fix it up?

  3. #3
    Registered User
    Join Date
    Jan 2009
    Location
    Alpharetta, GA
    Posts
    16
    In the 90's I had several K75's. I inadvertently locked up the ABS and the dealer could not clear the codes. I called a BMW electrics place in Alabama to ask about a used unit and was given the instructions to clear all the fault codes. It requires shorting a couple of pins and hitting the switches in a certain order. I was told a dealer could only clear one code at a time and if there were multiple codes (like hundreds) they would give up and replace the ABS control module. Anyway it worked fine. I believe I've seen the instructions somewhere in this forum.

  4. #4
    Unregistered user norton's Avatar
    Join Date
    Aug 2005
    Location
    Plano, TX
    Posts
    145
    Have you contacted http://www.modulemaster.com/en/index.php ?
    They might be able to advise you, or at least answer your questions about what the dealer told you.
    They fixed me up, and made me a satisfied customer.
    Last edited by norton; 08-12-2013 at 08:17 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •