Results 1 to 2 of 2

Thread: Narrowband O2 shift device test report

  1. #1
    Registered User
    Join Date
    Apr 2012
    Location
    Bend, OR
    Posts
    3

    Narrowband O2 shift device test report

    Narrowband O2 shift device test report

    I was lucky enough to be able to test Roger's pre-production narrowband O2 shift device. I installed it on my 2002 R1150GS (single spark). The installation is very simple - see the install writeup below.

    First, I want to say I hated having to remove it from my bike at the end of the test period. I will absolutely buy one when they become available.

    I also have an IICE Air IAT shoft device installed. Roger recommended having an IICE Air, Booster Plug or similar device installed. I had the test unit for approximately 600 miles. I rode in all kinds of conditions, from open highway, city streets, and light off-pavement riding. I rode in temperatures from 42 degrees to 78 degrees, both dry and in the rain.

    The first thing I noticed was the improved low RPM (2000-2500) roll on. It now actually pulled strong in the lower RPM range, especially in the first three gears.

    Second, it eliminated the little bit of low RPM surge I had prior to the install. It was easy to run in the 2500-4000 RPM range, especially at slow speeds.

    Third, it reduced the "snatchy" throttle when rolling off the throttle quickly. It was still there, but noticibly reduced.

    My fuel consumption appeared to be about the same, though I was a bit hard to tell as I rode the bike during the test period harder than I normally do.

    Additionally, these improvements increased after the initial install as the Motoronic adapted it's settings.

    Bottom line for me - the narrowband O2 shift device made very noticible improvements.

    Installation:

    First, remove the fuel tank. Note: it's much easier to do if it's not full. I seem to have a knack for filling it, then needing to do maintenance with a mostly full tank. Pull fuse #5 or disconnect the negative battery wires from the battery. This will reset the Motronic controller.

    Once the tank is off, locate the O2 sensor connector on the right side, usually on the frame rail.


    Remove the O2 connector from the frame rail.


    Disconnect the O2 sensor. Be careful as the little tabs are fragile. Connect the O2 device into the O2 connector.


    Secure the O2 connectors. I zip tied them to the frame. Secure the wire to the controller. As this was a temporary installation for testing, I used white zip ties to make removal easier.


    Locate a suitable place for the controller. I placed it on top of the air box, as a temporary location. Secure the wire from the O2 connector. Connect the ground wire to the negative terminal on the battery.


    Closeup of where I put the controller.


    Insert fuse #5 or reconnect the negative wires, as appropriate. Turn on the ignition, without starting, and roll the throttle 2-3 times through the full range of motion to make sure the TPS is calibrated to the Motronic.

    Start and ride!

  2. #2
    Day Dreaming ... happy wanderer's Avatar
    Join Date
    Mar 2010
    Location
    Vancouver, B.C. Canada
    Posts
    1,965
    Interesting report and some nice install photos also EkinOR. I know what you mean about having to remove it!

    Similar results on my test ride with the R1100 version can be found here: http://www.bmwmoa.org/forum/showthre...l=1#post880407

    I hope they are ready to ship soon!
    MJM - BeeCeeBeemers Motorcycle Club Vancouver B.C.
    '81 R80G/S, '82 R100RS, '00 R1100RT

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •