Results 1 to 5 of 5

Thread: Latest ABS glitch...need advice

  1. #1
    Registered User
    Join Date
    Jan 2013
    Location
    Sulphur, LA
    Posts
    13

    Latest ABS glitch...need advice

    Long story short on my '02 R1150RT... ABS lights flashing so I check the pads and rear pads are paper thin. I replace the pads all around and in doing so, get my fluid level too high which causes brakes to lock up the next day doing 45mph on service road to the interstate. I lower the fluid level and clean my shorts and brakes seem to work pretty well but ABS lights trip occasionally. Bike has been a little hard to start so I assume the battery voltage tripping the lights. Put new battery on bike and last two days haven't had the ABS lights come on. All seems well ...until...i pull in this afternoon and come to a stop and the pads won't release. Put bike in neutral but can't roll it. I have to turn off the key and switch it back on the ABS to run the self-test and then the brakes release. I know the benefits of ABS brakes and thought I'd like to keep them... I'm having serious thoughts of having the whole ABS system removed and go with the old school brakes. Any ideas what's causing this? Nearest BMW shop is almost 3 hrs from home. Thanks in advance!!

  2. #2
    Registered User
    Join Date
    Jun 2003
    Location
    Northern Front Range, CO
    Posts
    6,437
    plugged return line?

    did you bleed out your brakes, or just pull out some excess fluid? might be a good opportunity for a refreshing of fluid.
    Ride Safe, Ride Lots

  3. #3
    Registered User
    Join Date
    Jan 2011
    Posts
    5
    are your brake lines oem some times the lines brake down.the fluid level in the abs controller can cause the lights to come on see this article on abs maintenance really good infohttp://advwisdom.hogranch.com/Wisdom/service_abs3.pdf

  4. #4
    Registered User
    Join Date
    Mar 2007
    Location
    15 M. E. Tampa
    Posts
    382
    Just FYI - the 1150 uses a different sequence for the ABS that pretty much eliminates the low battery ABS failure syndrome, in that it does its startup after the engine is running.
    Everything you mention points to an internal hose failure which causes the lines to remain pressurized after you release the brake lever. Braided lines are probably the answer. If the brakes lock up again, try releasing the pressure at the caliper by opening the bleeder valve. If that works, then you have a bad brake line. Normal warnings about brake fluid eating paint, yada yada.

  5. #5
    Pepperfool GSAddict's Avatar
    Join Date
    Feb 2008
    Location
    Sechelt, British Columbia
    Posts
    1,309
    If you still have the old rubber brakes lines replace them with SS Teflon lines before going any further.


    They (rubber lines) are the cause of many mis-diagnosed ABS failures as well as posing risk to rider safety.
    Complete loss of braking circuit or locked calipers are the 2 main risks.
    I have changed over quite a few now and in 1 case of the locked caliper rear it has ruined the rotor as well.

    Eventually they ALL will do it - this includes the F650's
    I would not ride any machine that still has these lines for any distance.

    Replace the lines and flush with fresh fluid. Most probably this will solve the ABS fault and allow it to be reset. If the fault cannot be reset then, contact Modulemasters.

    Picture 2 shows a blocked port which caused the locked caliper. This debris works it way into the ABS module and the issues start.

    The complete loss is caused by grabbing the front brake hard, the line bulges, thus allowing the handle to go right to the bar with 0 braking action.




    '
    Ufda happens..........

    It's all about the details.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •