Results 1 to 5 of 5

Thread: Stalling issue revisited

  1. #1
    Registered User
    Join Date
    Jun 2014
    Posts
    4

    Stalling issue revisited

    Okay, maybe I'm beating a dead horse, but here goes.....

    My '05K12S (new to me) has been stalling on deceleration from freeway speeds and sometimes while shifting. Fueling, other than this issue, is great. I've researched the forums here and elsewhere, and have seen many different types of solutions, including:
    remapping with latest ECU software
    cleaning throttle bodies
    injector cleaner or other fuel additives
    butterfly adjustment to increase idle (never heard whether or not this worked)
    Power Commander or other aftermarket fuel mapping device
    replacement of various electronic and fuel system components

    I've cleaned the throttle bodies and run injector cleaner in the fuel, but the stalling issue persists. I'm debating either an ECU update at the dealer, or a Power Commander. I'm not sure if either option is a sure fix or not, but would appreciate any input on the subject. I have not seen recent posts on a definitive fix, other than 2010 dated posts on the software update working for the majority of bikes.

    Thanks for any help! My bike has 24,000 miles.

    Jeff in Colorado

  2. #2
    Registered User 58058D's Avatar
    Join Date
    Jun 2007
    Location
    Mendocino, CA USA about as far left as you can get in the lower 48
    Posts
    713
    You note that the bike is new to you. Have you checked with the local dealer to determine if all the factory updates/bulletins/recalls were carried out? My understanding is that several early suggested fixes later became fix-it bulletins for dealers as the bikes came through for other maintenance or service. I don't know about the earlier bikes, but the K13S issues were fully taken care of for the vast majority of riders. You should be able to call your VIN in to the dealer and have them look it up in the system to confirm any and all updates have been done, or not. Those with the earlier S will chime in to register their experiences, I am sure.
    Jim Douglas '00 K1200RS >135,000 miles my primary bike again,
    Gone: '09 K1300S sold @ 22k mi, '93 K1100RS traded @ 78k mi, '85 K100RS sold @ 44k mi
    '06 Kaw 650R track bike sold
    http://www.seagullbb.com/

  3. #3
    not so retired henzilla's Avatar
    Join Date
    Sep 2006
    Location
    between SanAntone & the Weird Place, TX
    Posts
    5,923
    Agree with Jim, Run the VIN at a dealer.
    The early bikes also had airbox issues that warped after a long ride. A redesigned box and idle valve fixed some issues.
    Steve Henson
    SABMWRA MOA Club#62's Flat Fixer/ current forum moderator
    It's not the breaths you take, but the moments that take your breath away-D.Dillon/G. Strait

  4. #4
    Registered User
    Join Date
    Jun 2014
    Posts
    4
    Thanks for the replies. All recalls have been done. I'm checking the airbox this weekend to see if it's warped at ambient temperature. I bought a used PC V with auto tuner to optimize fuel map for my bike. I've read there's a noticeable benefit compared to the factory tune.

  5. #5
    Registered User
    Join Date
    Jun 2014
    Posts
    4
    Airbox has been replaced, so that's not an issue. I have the PCV installed and all is well except the auto tune function won't read TPS when bike is running, but it will when engine is off and calibrating TPS. Any, DP tech is helping me with it. I think it may be that some of the firmware updates don't work for our bikes, while some obviously do based on owner feedback. DP guys are friendly and helpful, BTW, even though I bought a used PCV.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •