I have posted on this bike before. My new to me R1100R starts fine, runs a minute to 4 minutes then cr@ps out, by that I mean it goes into a mode where it emits smoke, soots the plugs, drops out ignition completely, then surges forward when throttle is opened. It may stop this and run good for 10 minutes then it returns, it is not rideable. The change in ride-ability is like a switch being thrown.
I have had suggestions: Oil temp sensor failure (no- Thanks rxcrider for the loaner), sync (no -spot on), valve adj (no -spot on), not fuel filter (replaced), not bad gas (removed and rinsed out), not hoses, not injectors, not hall sensors, not timing, not wiring (visual inspection and wiggle test), probably not wiring connectors (unplugged and replugged), new spark plugs, clean air filter and not anything two separately working former BMW master techs can find. BTW both have donated their time as they can't get it going, but I am gifting them a reward for effort.
Tuesday it goes into the local BMW dealer. The service manager asked if I had done a leak down test! I doubt this is the reason as when it runs it is strong, smooth, and accelerates like a gazelle in front of a lion. I guess I have to let them do one at $85/hr. I hope their diagnostic machine can find the problem.
Untested is the Engine Management Unit and the Throttle Position Sensor. I have both coming via ebay ($69 and $40- wow so cheap!) as the combined price new is $1600 (MaxBMW fiche). It looks like the EMU is an easy swop out, but the TPS would need to be set with the diagnostic machine and it will be in the shop anyway.
Could the Evaporative Emissions canister be the cause of this? I have read the Canisterectomy postings on .ADV forums and I am considering removal as I am desperate. I'll probably wait until the dealer has a go.
The bike is at one of the former tech's shop now. I haven't checked: grounding suggestion. It only has 6K on it and nothing outside of the bike looks even remotely warn, no chafed wires, no scuffs, no corrosion, it seems perfect.
I even called the 2nd owner and introduced myself to ask about its rid-ability in the past (it got a great review).
Anyone been through anything like this? What does the dealer's diagnostic machine tell? What am I missing here?
Ralph