Results 1 to 6 of 6

Thread: Devilish stalling problem 2007 F800ST

  1. #1
    The Big Red One sgtbill's Avatar
    Join Date
    Jul 2006
    Location
    Herndon, VA
    Posts
    159

    Devilish stalling problem 2007 F800ST

    My dear wife bought a used F800ST a few years back. Almost immediately she mentioned it would stall when she was down shifting as she rode toward a traffic light that had changed to red. The stalling would not appear until she had been riding for more than an hour or so. We have had the bike in to have the problem fixed several times over the past few years. We have replaced a hose that sometimes collapses causing stalling and it still stalls. We have had injector cleaner run through the engine and it still stalls. Recently the problem has become more acute in that the bike stalls more frequently as you ride. And gets harder to restart after a stall. A couple of weeks ago it was at the dealer and they diagnosed a crankshaft sensor malfunction so that was replaced and it still stalls. The next attempt was to remove the canister attached to the fuel tank relief hose and it still stalls. I rode the bike this morning to see if the canister removal improved things. After 2 hours of riding and about 100 miles it stalled at a stop sign and continued to stall for the next hour until I made it home. One new symptom appears to be an electrical hiccup. Twice while attempting restart the instruments turn off completely. Just like the key was turned off. It only lasts about 3 to 5 seconds before it reinitiates (the speedo and tach flip all the way to the right) and then I was able to restart. But it kept stalling. I'm not sure the electrical symptom is related or just a mean-spirited coincidence. Anyone have any ideas?

    I've read several threads on the stalling problem and don't see a common cause to any of them. We're quite frustrated by this and will probably trade the bike back to the dealer in the next few months. We were thinking of a F800GS or the F800GT but are concerned there may be stalling issues with any F800.
    sgtbill
    Duty First!
    86 K100RS EML
    2007 F800ST & 2014 F800GS & 2014 F700GS

  2. #2
    Benchwrenching PGlaves's Avatar
    Join Date
    Oct 2003
    Location
    "Big Bend" TX
    Posts
    8,614
    I suspect it might have a faulty engine temperature sensor. Voni's F800S did this on very hot days until the sensor was replaced. Just a guess, but ...
    Paul Glaves - "Big Bend", Texas U.S.A
    "The greatest challenge to any thinker is stating the problem in a way that will allow a solution." - Bertrand Russell
    http://www.bigbend.net/users/glaves

  3. #3
    Registered User
    Join Date
    Jun 2003
    Location
    Northern Front Range, CO
    Posts
    6,406
    no thoughts on the problem, but my in 30K miles, my F8GS only had a stalling issue prior to it's getting the canister recall done. but that was only 1 or 2 times, only in the rain.
    Ride Safe, Ride Lots

  4. #4
    The Big Red One sgtbill's Avatar
    Join Date
    Jul 2006
    Location
    Herndon, VA
    Posts
    159

    Gonna take it to the dealer

    And try to get them to force the software update. I'll have my wife let them know to check the engine temp sensor as well. I'll let you know what happens then.
    sgtbill
    Duty First!
    86 K100RS EML
    2007 F800ST & 2014 F800GS & 2014 F700GS

  5. #5
    The Big Red One sgtbill's Avatar
    Join Date
    Jul 2006
    Location
    Herndon, VA
    Posts
    159

    Dang that software anyway

    Karla's bike went back to the dealer after they found the stalling cause with a GS-911 fault with the crankshaft sensor. Replaced that and it still stalled after 90 minutes of riding. Hard to get the dealer to test ride something that long. On Wednesday they took it back and issued Karla a loaner F800S. First a check of battery and fuel delivery then finally a check of firmware. Guess what, never been updated. A force of the update and the maintenance super rode it home that night. On Friday we picked it up and for the first time in several years it ran flawlessly for the weekend. Three days in a row of + 6 hour riding days without a flinch. What a relief. Our plan is to give this bike to our daughter next year after several different rider training courses.... Can't do that if it is stalling. On the good side the maintenance outfit didn't charge us for the additional tinkering required to get to the solution which avoided a head-butting contest I'm sure neither of us would have enjoyed.
    sgtbill
    Duty First!
    86 K100RS EML
    2007 F800ST & 2014 F800GS & 2014 F700GS

  6. #6
    Registered User
    Join Date
    Apr 2013
    Posts
    4

    engine temp sensor

    Quote Originally Posted by PGlaves View Post
    I suspect it might have a faulty engine temperature sensor. Voni's F800S did this on very hot days until the sensor was replaced. Just a guess, but ...
    Paul, did you replace the water temp sensor or the air temp sensor. also, do you use any sealer on the valve cover gasket?

    thanks, John
    Last edited by flightdog55; 05-29-2013 at 12:38 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •