Results 1 to 15 of 17

Thread: 85 R80 stalls when throttle applied from idle

Hybrid View

  1. #1
    Registered User jimbc's Avatar
    Join Date
    Jun 2012
    Location
    Ontario, Canada
    Posts
    61

    85 R80 stalls when throttle applied from idle

    The engine of my 85 R80 intermittently stalls when I open the throttle to accelerate from a stop. I was able to duplicate the concern while standing beside the bike and noted a popping sound and saw a puff of smoke from the right carb.

    It concerns me when it happens at a intersection when the light turns green.

    I'm posting this because I'd like to understand what's happening when it stalls and why. Thanks for your input.

    Jim
    1985 R80 Original owner

  2. #2
    Administrator 20774's Avatar
    Join Date
    Sep 2005
    Location
    San Antonio, TX
    Posts
    13,181
    Sounds like maybe your idle circuit needs tweaking or you need a carb synch. Try changing the idle air mixture screw small turns (1/8 to 1/4) in one direction on both carbs. See if the problem improves or gets worse. If you find one direction helps, then consider checking the entire carb synch process to get it dialed in better.
    Kurt -- Forum Administrator ---> Resources and Links Thread <---
    '78 R100/7 & '69 R69S & '52 R25/2
    mine-ineye-deatheah-pielayah-jooa-kalayus. oolah-minane-hay-meeriah-kal-oyus-algay-a-thaykin', buddy!

  3. #3
    Registered User jimbc's Avatar
    Join Date
    Jun 2012
    Location
    Ontario, Canada
    Posts
    61
    Thanks Kurt
    1985 R80 Original owner

  4. #4
    Registered User lmo1131's Avatar
    Join Date
    Jan 2010
    Location
    Pismo Beach, CA
    Posts
    3,051
    JIm, when was the last time you went through the ignition adjustment / plugs/ valves drill? It's always nice to know when everything is "zeroed" out.

    The last time I encountered a "popping and spitting" situation it turned out to be tiny bit of grit that found it's way to the right side main jet. When was the last time your carburetors were off and cleaned?
    "It is what you discover, after you know it all, that counts." _ John Wooden

    Lew Morris
    1973 R75/5 - original owner

  5. #5
    Registered User jimbc's Avatar
    Join Date
    Jun 2012
    Location
    Ontario, Canada
    Posts
    61
    Thanks Lew. The last time the carbs were done was 2008. I plan on taking the bike to the local airhead tech for this and to have the splines lubed for another problem I'm having. In the mean time I'm trying to gain an understanding of what's going on. Jim.
    1985 R80 Original owner

  6. #6
    Luddite Looney wecm31's Avatar
    Join Date
    Jun 2009
    Location
    Eganville, Ontario
    Posts
    348
    Where are you in Ontario??

    I'll be hosting a Tech Day at my place near Eganville (Ottawa Valley) June 22/23.

    I'm sure our collection of experts could verify your carb tuning and even get
    those splines lubed, all within our body of past experience.

    Check your Airmail for details of shoot me a PM...
    Gerald P
    The last thing I want to be is just like everyone else...
    1985 R80RT
    1969 Sport Fury Convertible

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •