Here's the story - please help me diagnose my fault.


1) The bike has been running like a champ since I put it back on the road on January 1st. No operating issues whatsoever at any speed or under different loads.

2) I've been riding the bike every day now for two weeks. My commute is 25 miles each way. No problem.

3) Yesterday I rode with my mates to a bike show 25 miles from my house.

4) On the way home it faltered once. The stumble was short - so short I almost missed it. It did not happen again that day even though I rode for another 30 miles in another direction (went to check out a bike with my Ducati riding buddy).

5) Rode the bike to work this morning as usual.

6) On the ride home - I had traveled about a mile and the bike dies. No partial power - dead. Roll to a stop on the side of the road.

7) It felt like I hit the kill switch - but I didn't and the lights on the dash were on.

8) I turned everything off - then back on and tried again. Lights are all on - and it turns over normally.

9) No start - No pops - no rumbles, no anything except kee-kee-kee-kee-ka-whirrrrrr as I let my finger off the start button.

10) I unplug the computer seems tight. Plug it back in - goes together well - try again - no joy.

11) At that point I push it the one mile back to work and park it. My buddy was ready to give me a ride home so I didn't spend anymore time on it.

12) While I was waiting for him to get the car I tried turning it over a few times and smelled for raw fuel at the tailpipe. Not a great test - but I didn't smell a thing.

So tomorrow I will check for spark using an ignition tester (the brass gap type of device). Assuming I see a spark - what should I check first on the fuel system - power to the pump I suppose. How do I best go about that? (I have a multimeter and know how to use it).

I'm kind of gut-thinking my computer may be toast. Do the systems I describe support that? How does one go about testing the computer?

How do I best test for fuel flow while cranking?


Thanks for any help gents.