Results 1 to 13 of 13

Thread: Fuel delivery system and surging/buckling

Threaded View

  1. #1
    Registered User amtoro's Avatar
    Join Date
    Jun 2012
    Location
    Atlanta, GA
    Posts
    26

    Fuel delivery system and surging/bucking

    For months, I had been experiencing one of the most annoying surging conditions on my '04 R1150RT; with the help of some of our chartered club members, we did a conscious valve adjustment, changed the fuel filter and TBS with little to no improvement.

    A constant misfiring was also occurring, and after troubleshooting with a new ignition coil (which ended up replacing the oldest one still on the bike as one had already been replaced by the previous owner), the misfiring went away after another TBS.

    So, fuel delivery seemed to be ok, air delivery was also fine, and the spark was strong with new spark plugs installed at the time of the valve adjustment. However, there was a noticeable lag when applying quick throttle, and a hesitation and buckling while accelerating; only under very light throttle, I could increase speed in a more-or-less linear way.

    At this point, with a warm engine and after coming to a stop, the bike would slow down to a nice tickle and idle fine at about 1,100rpm for about 30 seconds and then just stall... it would start fine, and then stall again without warning. I was also experiencing difficulty warming up the bike in the mornings unless I was manually opening and closing the throttle.

    Two weekends ago at Rider's hill in Dahlonega, GA, at the final stop of a day ride with the local group, and after discussing my maladies with other two 1150RT owners, one of them directed me to another rider who, according to him, knows RT's better than most.

    After describing the condition to him, he replied that the best thing I could do was to have the injectors professionally cleaned. He said he didn't have to hear the bike, but then asked me what mileage it had; 42k, I replied... he ratified his diagnosis, we shook hands and I left.

    I didn't mention this to him, but I had tried a few bottles of injector cleaners and they tried to improve the condition with minimal effect, so I thought he could, very well, be on the right track.

    Fast forward to yesterday. I received my injectors back from ProFlow and installed them after looking at their report where stated that their spray pattern was good before the cleaning, but that the flow rate was apart from each other and a bit low; the report indicated an improvement in the flow rate of 5.6% for one of them and 8.3% for the other. Not much in my opinion and the voice in my head was saying that I had just thrown my money away.

    Start... perfect idle... test ride... it is like I'm riding a horse out of hell. The bike delivers its power completely lineal from bottom to top, all the way to the top! this is the bike I fell in love with and it is back.

    My suggestion is: Consider the possibility of a lightly clogged injector if the power delivery does not feel right and if there is something irregular at idle (when little fuel in being injected, the lack of enough flow will magnify the problem). I think I will send my injector for cleaning every 36k-42k miles and run a bottle of teckron for maintenance every 10-15 fill-ups.
    Last edited by amtoro; 04-23-2013 at 06:45 PM.
    '04 R1150 RT

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •