Page 2 of 2 FirstFirst 1 2
Results 16 to 18 of 18

Thread: 2010 RT Rear Brake Pad Fit Problem

  1. #16
    Registered User
    Join Date
    Mar 2011
    Location
    Lawrenceville,ga
    Posts
    142
    I installed new rear brake pads yesterday on my 06 R12RT. Had the same problem. Removed the old pads, AND the new ones wouldn't fit. I remembered reading something about this previously. Searched and found this very helpful information. Spread the caliper out and squirted a little brake cleaner to clean it up. Voila, the pads slid into place.

    I really appreciate the helpful servicing tips and info that can be found here.

  2. #17
    God? What god? roborider's Avatar
    Join Date
    May 2007
    Location
    Raleigh, NC
    Posts
    2,064
    I have to second that. I do all my own work and this forum has been invaluable to me in this respect. People tell me I know so much about my RT and my airhead. Forgive me for not divulging my sources!
    Rob C. , Raleigh, NC
    '10 R12RT, R90/6
    2007 CBR600RR & 09 V-Star
    Suzuki DR 350

  3. #18
    Droptine1968
    Join Date
    Feb 2013
    Location
    Toledo, Ohio area
    Posts
    53
    I realize this is an old thread. On my 2005 R1200rt, I put EBC pads on the rear, spun the tire and alot drag on the rotor. I put the old pads, back in, no drag. My BMW pads weren't completely gone and still within normal wear lines but getting close. I changed sets back and forth three times and had the same issue with the EBC pads each time. I thought I was doing something wrong. Next time at the dealer for other work, I had them replace the rear pads, I did not bring in the set I'd had issues with. They suggested the EBC's but they had the same issue I did and ended up using BMW OEM's. I had no problems both pair of EBC's on the front.
    2005 R1200RT

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •