Page 2 of 2 FirstFirst 1 2
Results 16 to 17 of 17

Thread: R1150 Alternator Start-Up Fix & AFR

  1. #16
    Pepperfool GSAddict's Avatar
    Join Date
    Feb 2008
    Location
    Sechelt, British Columbia
    Posts
    1,294
    Quote Originally Posted by Acejones View Post
    And you are proud of this ?
    +1
    '
    Ufda happens..........

    It's all about the details.

  2. #17
    Registered User roger 04 rt's Avatar
    Join Date
    Oct 2011
    Location
    Massachusetts
    Posts
    1,284
    For anyone who enjoys the insight of graphs, here's a good example of the alternator coming on late. It was before I figured out what was going on.

    Looking at the curve below from 40 seconds to 60 seconds you can see the START-UP enrichment program being run. In that period, the Motronic is gradually reducing the enrichment.

    At the 60 mark, until about the 2 minute mark, the Motronic is holding the length of the fuel pulses fairly steady, but it looks as if the mixture is getting richer. This is because as the engine warms up, more of the fuel gets burned and there is less oxygen in the exhaust. And what the O2 sensor is measuring is oxygen which effectively means mixture.

    The from the 2 minute mark until about 5:10, the Motronic is gradually reducing the fuel as the engine warms further. But you can see at 3:20, the mixture steps down. This is exactly when my alternator started charging. The injector pulses didn't get longer (in fact they got a little shorter as the Motronic uncompensated for the low voltage) but the Battery Voltage got higher and the injector turn-on time got shorter and they squirted a bit more fuel--roughy 7% more.

    Had the alternator been running from the beginning, the first 3:20 of the graph would be shifted down by about 7% richer.

    Finally just before 5:20, the Motronic goes Closed Loop and settles on +- 13.8:1.



    Here is a clean start of my R1150RT with everything working as it should on a day when my garage was about 45 degrees, same as above. You can compare it to the previous graph where there is the step down due to the alternator coming on late at 3:20 on that graph.

    Because my mixture is richer than standard, the start-up is richer too but it seems to work fine.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •