Results 1 to 15 of 27

Thread: 1992 K75S ABS light constantly on

Hybrid View

  1. #1
    broadstone
    Guest

    1992 K75S ABS light constantly on

    In another discussion I broght up the multitude of problems with an "as is" not running K75 that sat unused for at least 2 years. With the help of several members I now have it running pretty well but with some remaining issues. The ABS light is on as soon as the ignition key is turned on but remains on solid no matter what else is done such as setting with the brake while riding or toggling the ABS switch. Many of the problems I've had we're electrical related so I suspect it may be related to that. Also, I believe that the left front caliper is frozen and am wondering if that could be related to the ABS indicator lamp staying on. The fuses are good and this is my third BMW with ABS so I'm familiar with the procedure for having this light turn off. I think I'd be more comfortable with the problem if the light was at least flashing. Any assistance would be appreciated.

  2. #2
    3 Red Bricks
    Join Date
    Jan 2007
    Location
    Pleasanton, Ca.
    Posts
    3,347
    Jim,

    First thing I would try is to reset the ABS.

    http://ibmwr.org/ktech/abs-reset2.shtml

    Only comments I have about the above link is the connector or the plug in the connector will be light blue. Push the ABS switch for 60 seconds as opposed to 20 seconds. Exact time doesn't matter, but sometimes it takes longer than 20 seconds.

    It might be the only problem, might not.



    LONG MAY YOUR BRICK FLY!

    Ride Safe, Ride Far, Ride Often

    Lee Fulton Forum Moderator
    3 Marakesh Red K75Ss
    Mine, Hers, Spare

  3. #3
    broadstone
    Guest

    K75 ABS probs

    Thanks, Lee. I forgot to mention that the battery is reading 10.2 volts and much higher with the engine running and the brake light is working. I'll look into the reset solution as soon as I find clear instructions for doing this.

  4. #4
    Registered User
    Join Date
    Dec 2006
    Posts
    131

    k75abs problem

    Need a new battery, me thinks. That will start solving the abs problems.

  5. #5
    BMW uber alles! Zagando's Avatar
    Join Date
    Apr 2007
    Location
    Rockport, TX
    Posts
    1,085
    Exactly the same problem I encountered twice over the last four years---the culprit was low resting voltage---replace the battery* and reset the ABS using the ground wire trick and I bet you'll be good to go thereafter.

    (Or if it's been sitting for a long time a good full recharging might suffice but make sure it can hold a decent charge. IIRC the resting voltage should be at least 12.4 volts but if I'm a bit off on that perhaps Lee or someone else can correct me).

    It really helps to know the fault code and next you're near a Radio Shack pick up a 12 volt LED part # 276-011 (I know it by heart!) to use as your Official BMW ABS Fault Code Reader. $2.95 + tax; expensive but worth it!
    ---Jeff

    ex: K75S Berlina R100GS/PD , K100RS , R75/5 , R60/2

  6. #6
    BMW uber alles! Zagando's Avatar
    Join Date
    Apr 2007
    Location
    Rockport, TX
    Posts
    1,085

    Thumbs up Recommendation if you need a new battery

    PS: If you do need to replace the battery I can totally recommend an outfit called Euromoto Electrics up in Denver---after searching on the Internet a good while they had the best price with shipping overall---and their service and packing was exemplary. I went with the heftier Westco 30AH job and I suspect it'll serve me well, too.
    ---Jeff

    ex: K75S Berlina R100GS/PD , K100RS , R75/5 , R60/2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •