Page 1 of 2 1 2 LastLast
Results 1 to 15 of 18

Thread: Windscreen stuck intermittently? 2012-R1200RT

  1. #1
    Registered User Gadgetech's Avatar
    Join Date
    Aug 2012
    Location
    Greenville, SC
    Posts
    120

    Windscreen stuck intermittently? 2012-R1200RT

    This is the second time in probably a month and a half that I've gotten on my bike and went to adjust the windscreen up and it wouldn't budge. There haven't been any indications that something is broken and the screen has worked previously in the day before not working. Both times the windscreen has been in the full down position.

    The first time it happened I was riding along, adjusted my screen down and then maybe 5 minutes later tried to adjust it up and it wouldn't move. About 10 minutes after that it worked fine and has up until 30 minutes ago.

    This time, I adjusted it down and parked it shortly there after for about 30 minutes. I got back on the bike and the screen wouldn't budge for my whole ride back to work which was about 20 minutes.

    Has anyone had these issues or are you able to suggest what might be the issue. I'm sure if I take to the dealer, it'll work by the time they get to look at it.

  2. #2
    Registered User mneblett's Avatar
    Join Date
    Nov 2005
    Location
    Fairfax, VA
    Posts
    1,729
    Quote Originally Posted by Gadgetech View Post
    Has anyone had these issues
    Yes.

    Quote Originally Posted by Gadgetech View Post
    or are you able to suggest what might be the issue.
    Dead/dying left grip cluster switch. BMW is *still* having problems with the new design switch clusters. Warranty replacement.
    Mark Neblett
    Fairfax, VA
    #32806

  3. #3
    Registered User Gadgetech's Avatar
    Join Date
    Aug 2012
    Location
    Greenville, SC
    Posts
    120
    Nice, thank you for the info.

  4. #4
    Registered User mneblett's Avatar
    Join Date
    Nov 2005
    Location
    Fairfax, VA
    Posts
    1,729
    No problem. The second owner of my K16GTL has experienced the same windshield problem, and my '12 R12RT had its right switch cluster replaced for a defective starter switch.
    Mark Neblett
    Fairfax, VA
    #32806

  5. #5
    Registered User
    Join Date
    Sep 2008
    Location
    Wilmington, NC
    Posts
    2,035
    The older switches had their issues, too, but the ones on my 08 RT and 06 K GT have been fine. The new switch design was supposed to be an improvement but seems more like just another bit of cost cutting for manufacture- there are quite a few reports of failures of what ought to be an easy 100% reliable part..

    Just get it on record and get your dealer to replace it eventually- covered by warranty.

  6. #6
    Registered User Gadgetech's Avatar
    Join Date
    Aug 2012
    Location
    Greenville, SC
    Posts
    120
    It still isn't working. My hope is that'll be the case in the morning when I take to the dealer. Any bets?

  7. #7
    Registered User Gadgetech's Avatar
    Join Date
    Aug 2012
    Location
    Greenville, SC
    Posts
    120
    And of course it works just fine this morning.

  8. #8
    Registered User Gadgetech's Avatar
    Join Date
    Aug 2012
    Location
    Greenville, SC
    Posts
    120
    Fortunately they were able to duplicate the issue and are ordering a new switch.

  9. #9
    Registered User
    Join Date
    Mar 2013
    Location
    Port Coquitlam, BC, Canada
    Posts
    2

    2011 r1200rt

    Mine is stuck as of today! Pulled into my garage after a full days ride, went to put the windscreen down and .......nothing.....Arrgghhh.......off to the dealer!

  10. #10
    Registered User liv2ride's Avatar
    Join Date
    May 2012
    Location
    Honolulu, HI
    Posts
    187

    Wow...

    Quote Originally Posted by mac1054 View Post
    Mine is stuck as of today! Pulled into my garage after a full days ride, went to put the windscreen down and .......nothing.....Arrgghhh.......off to the dealer!
    Sorry to hear your first post is not a positive one. If your bike is still under warranty don't hesitate bringing it in for a warranty replacement. There is apparently a new part number for the left cluster that is expected to correct the issue.

    Feedback from those who have experienced issues is that the switches that fail did not have a discernable feel when pressing but the newer model number switch does.

    Anyway, welcome to the forum and I hope once past this issue your ownership is filled with many happy and memorable miles.

    Aloha.

    Scot

  11. #11
    Registered User
    Join Date
    Mar 2013
    Location
    Port Coquitlam, BC, Canada
    Posts
    2
    Quote Originally Posted by liv2ride View Post
    Sorry to hear your first post is not a positive one. If your bike is still under warranty don't hesitate bringing it in for a warranty replacement. There is apparently a new part number for the left cluster that is expected to correct the issue.

    Feedback from those who have experienced issues is that the switches that fail did not have a discernable feel when pressing but the newer model number switch does.

    Anyway, welcome to the forum and I hope once past this issue your ownership is filled with many happy and memorable miles.

    Aloha.

    Scot
    Aloha Scot, even with the "fail" the day was still excellent and this problem should be covered under warranty. A minor inconvenience but these things happen.

    Cheers,

    John

  12. #12
    Webb Benninghoven
    Join Date
    Feb 2012
    Location
    Cape Coral, Florida
    Posts
    51
    It appears to be intermittent...potentially as a heat related issue as it works it's way to failure. It seems that the culprit is an internal flat circuit board issue, that affects some of the R bikes with the "new" switch gears, and some of the K bikes. Some go bad & some do not. I haven't heard it so much on the GS of any of the models, but those bikes aren't bikes we see in a lot.

    I haven't heard of any of the replacement ones having any issues...

    Those are my observations.

  13. #13
    BMW Rider
    Join Date
    Apr 2013
    Posts
    750
    Quote Originally Posted by mneblett View Post
    No problem. The second owner of my K16GTL has experienced the same windshield problem, and my '12 R12RT had its right switch cluster replaced for a defective starter switch.
    I have seen a K16 with this very problem one time. I no longer remember the specifics but attaching the bike to the BMW diagnostic equipment, which recognized there was a windshield issue, was actually able to resolve it by a few key strokes. Not saying this will resolve your particular problem but it's worth a shot.

  14. #14
    Registered User
    Join Date
    Apr 2010
    Location
    Mission, TX
    Posts
    270
    I think you are having major problem. The switch is suppose to fail to lower the windscreen not fail to raise it.

    I'm being sarcastic. The left hand switch gear fails often (I've gone through 5).

    tsp
    My Blog: http://www.airheadmoto.com

    Quote Originally Posted by Gadgetech View Post
    This is the second time in probably a month and a half that I've gotten on my bike and went to adjust the windscreen up and it wouldn't budge. There haven't been any indications that something is broken and the screen has worked previously in the day before not working. Both times the windscreen has been in the full down position.

    ...

    Has anyone had these issues or are you able to suggest what might be the issue. I'm sure if I take to the dealer, it'll work by the time they get to look at it.

  15. #15
    BMW Rider
    Join Date
    Apr 2013
    Posts
    750
    Quote Originally Posted by tsperez View Post
    I think you are having major problem. The switch is suppose to fail to lower the windscreen not fail to raise it.

    I'm being sarcastic. The left hand switch gear fails often (I've gone through 5).

    tsp
    My Blog: http://www.airheadmoto.com
    Nice blog. Question: Can you have a job and still ride 1 million miles?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •