Results 1 to 4 of 4

Thread: 2007 R1200RT Stumble

  1. #1
    Registered User
    Join Date
    Aug 2011
    Posts
    61

    2007 R1200RT Stumble

    I have a 2007 1200rt with 17,000 miles and generally speaking, it runs fine. WHen ever it is under heavy load and I open the throttle wide open, it frequently stumbles for a second. Any ideas on things to check?

  2. #2
    Proud Veteran SteveAikens's Avatar
    Join Date
    Mar 2003
    Location
    Clovis, NM
    Posts
    942
    Could be something as simple as condenation in the fuel or poor quality fuel. Plugs, elevation, dirty air filter, dirty fuel filter etc. Without knowing more - for example, where you're located - it's hard to get an idea of the problem.
    Nom de Plume:
    Steve Aikens, Clovis, NM
    BMW MOA #6218
    IBA# 442

  3. #3
    Registered User
    Join Date
    Aug 2011
    Posts
    61
    in Nashville Tennessee . Elevation 700 feet. Temp mid 70's when I saw the issue last. (I dont get wide open throttle much). It has the original spark plugs

  4. #4
    A bozo on the bus deilenberger's Avatar
    Join Date
    Mar 2003
    Location
    Spring Lake NJ, USA
    Posts
    7,732
    At that mileage the plugs should still be OK, and you don't have a fuel filter so that's not an issue (only the R12R has an in-line fuel filter on hexheads), and I doubt if the airfilter is an issue, it will reduce power but won't cause a stumble.

    So - my WAG - might be one of the stick coils breaking down under higher loads. Problem is - which one.. that's hard to test, especially if it only does it at high load conditions. The way dealers troubleshoot this is to replace them one at a time, which for an owner (who has non-returnable electrical products) gets costly. I'd be suspicious of the primary (center) coils.. and luckily, those are interchangeable so you'd only have to buy one to test this. The secondary coils aren't - they're specific to the side they're on.

    Once in a while you'll spot a coil, or a set of coils on ebay from a wreck. I picked up a set about 5 years ago - 4 for $100 (from Israel.) Came in handy when my bike started developing a rough idle at times. It was one of the center coils. Not sure which one since I swapped out both at the same time. Have to put the old ones back in sometime and see if I can determine which coil was going intermittent on me. Unfortunately - unlike car ECU's - the hexhead ECU doesn't detect, or doesn't store any misfire codes.. that would make it much easier to troubleshoot.

    BTW - it is worth checking the gap on your plugs. It could likely stand to be reset by now. Can't hurt, and sometimes will help if a coil is marginal and only breaks down under heavy load conditions.
    Don Eilenberger http://www.eilenberger.net
    Spring Lk Heights NJ NJ Shore BMW Riders New Sweden BMW Riders
    '07 R1200R (current ride) and some bimmers.. and a Porsche

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •