Results 1 to 4 of 4

Thread: 1994 K75S Tapping In Oil Seal on a Water Pump

  1. #1
    Slipster Slipster's Avatar
    Join Date
    Jun 2012
    Location
    Broken Arrow, OK
    Posts
    72

    1994 K75S Tapping In Oil Seal on a Water Pump

    I thought I had better start a new thread as this aspect of my situation now has nothing to do with Water Pump Sealant

    I am looking for guidance on installing the oil seal into my water pump. Open end points to the oil side of the pump - got that. The instructions say to tap into place using a hammer and a 19mm socket. This is where I don't get it.

    The seal just drops in with no effort. I am tapping it into what and how far?

    The seal appears to be the correct size and does marry up to the water seal ok.

    I just need some deja vu
    Expect The Unexpected

  2. #2
    Dum vivimus vivamus ted's Avatar
    Join Date
    Mar 2003
    Posts
    2,576
    There are some good Youtube videos showing people doing it - here is a good one for a K1100, same concept

    http://www.youtube.com/watch?v=j8JUY...feature=relmfu
    Ted
    "A good stick is a good reason"
    1994 K75RT
    Moto Pages

  3. #3
    Slipster Slipster's Avatar
    Join Date
    Jun 2012
    Location
    Broken Arrow, OK
    Posts
    72
    The old metal rim was still in there - Back to clean up
    Last edited by Slipster; 10-22-2012 at 09:03 PM. Reason: Found out the problem
    Expect The Unexpected

  4. #4
    Slipster Slipster's Avatar
    Join Date
    Jun 2012
    Location
    Broken Arrow, OK
    Posts
    72
    Installed the seals. Used ThreeBond Sealant. Installed and let the gasket sealant cure.
    Put fluids in. Took it for a ride. No anything out the weep hole. No anything around the pump. Whew!. Thanks to all for your great guidance and support.

    Everything is easy once you know how
    Expect The Unexpected

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •