Results 1 to 5 of 5

Thread: 1975 R75/6 Tachometer & Cable

  1. #1
    Registered User
    Join Date
    Nov 2006
    Posts
    2

    1975 R75/6 Tachometer & Cable

    1975 R75/6. Tachometer went south. I've got a replacement unit as well as a new cable. Got the new unit in the instrument cluster, will send the bad one to Overseas Speedometer (unless someone knows of a better place).

    Any hints re replacement of cable? Any tricks?

    Lube or not lube (if so, with what; procedure?)? Any grease (if so what kind) on the fittings (e.g., cable to tach unit)?

  2. #2
    Sir Darby Darryl Cainey's Avatar
    Join Date
    Mar 2003
    Location
    Fenwick, Ontario Canada
    Posts
    2,167
    Quote Originally Posted by EMH View Post
    1975 R75/6.

    Lube or not lube (if so, with what; procedure?)? Any grease (if so what kind) on the fittings (e.g., cable to tach unit)?
    New cables are teflon lined, no lube is needed.
    Ambassador BMW MOA Ontario Canada
    President Niagara BMW Riders #298
    Knights of the Roundel #333
    1977 R100RS, (Retired) 1993 R100GS (just getting started)

  3. #3
    P Monk
    Join Date
    May 2005
    Location
    Port Neches, Texas
    Posts
    655

    overseas speedometer

    I sent my speedo and tach to him for repair. Both have worked perfectly since. The speedometer now reads within 1 mph of my Zumo, where before it read about 10% faster than the gps.
    P. Monk
    74 R90/6 (also know by bride as the Black Hole). 09 R1200 GS. My wife, 1953 model who has survived aplastic anemia and a bone marrow transplant.

  4. #4
    Registered User bmweuro's Avatar
    Join Date
    Oct 2009
    Location
    Northern Cal
    Posts
    255
    I just replaced the tach cable in a /6 and I noticed if you do not route it exactly how BMW did it fits like it is to long so make note of exactly how it was installed before removing it. Also where the front cover fits over the rubber boot use a little WD-40 or something like it. It will make a lot easier to get the front cover on.
    www.boxermetal.com
    www.facebook.com/boxermetal
    VBMWMO #7770, BMW MOA #48694, ABC #600
    Hi my name is Chris and I am a slash-five-o-holic.

  5. #5
    Registered User
    Join Date
    Nov 2006
    Posts
    2

    Rubber tachometer housing

    My trick for getting the timing cover back on is to:

    1. Take the tube out of a Armour All spray bottle,

    2. Run the tube between the two edges of the tachometer cable rubber housing that are facing out

    3. Line up the timing cover over the rubber housing (with the tube still splaying out the two edges)

    4. Slip out the tube while pressing in the timing cover.

    This way there is less possibility of crimping the new housing

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •