Results 1 to 5 of 5

Thread: poor acceleration

  1. #1
    richardswork
    Join Date
    Apr 2011
    Location
    bluffton sc ,palm city fl
    Posts
    6

    poor acceleration

    1........checked valves
    2....changed fuel filter
    3..changed spark plugs
    4...changed co2 cartridge
    5.removed carbon filter
    all above no help
    6.........changed spark plug caps..............runs like a neww bike now ......hope this helps someone ....i spent alot of time and alot of frustration before finally got it corrected ..............also had alot of advice on what to do without any good results ....

  2. #2
    just hangin' out 2bikemike's Avatar
    Join Date
    Oct 2005
    Location
    Knoxville,TN
    Posts
    1,167
    What kinda bike we talkin' bout Willis? And if you don't know who Willis is....http://www.youtube.com/watch?v=Qw9oX-kZ_9k
    keep it light enough to travel.....
    '04 R1150RT
    '81 Honda CB650 Custom

  3. #3
    Registered User Bmandiego's Avatar
    Join Date
    May 2012
    Location
    Escondido
    Posts
    640
    yeah,
    and why does it have a co2 cartridge? Does it shoot pellets or bb's??
    2000 R1100RT-P

  4. #4
    Registered User roger 04 rt's Avatar
    Join Date
    Oct 2011
    Location
    Massachusetts
    Posts
    1,212
    Profile says it's a 2004 1150GS. Bet the co2 cartridge is the O2 sensor.

  5. #5
    richardswork
    Join Date
    Apr 2011
    Location
    bluffton sc ,palm city fl
    Posts
    6

    Smile poor acceleration

    yes it is a 2004 gs and scuse the slip on the o2 sensor ..........but the bottom result is that the problem has been fixed and the bike is running great and the information is important to anyone with similar problem ............the end............

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •