First time posting as I have had a good run up to this point with the bike. Now, unfortunately, I am at a loss as to what to do...

1993 K75S with about 2k miles on it. Original owner. Was running fine, as I use it twice a week to commute a few miles to work, until it tipped over to the right side in the garage. Cracked the upper fairing and saddle bag. Got the replacement parts and it is all back to 100% cosmetically.

When the bike fell over though, it leaked out oil from the filler cap. Not a lot, maybe 1/2 to 3/4 of a cup. Well, in the haze of being pissed off and upset, I got the bike back up and started it up right away. Started fine and ran with no issues for a couple of minutes. In the meantime, I had the bike towed up to the local dealer to have an ABS problem fixed. They checked over the bike and said all looked okay. Fixed the ABS issue, test rode it and gave me the bike back.

Trailered the bike back yesterday. When I got home, I started the bike and it billowed white smoke out of the tail pipe. Figured it could be that they had it on then side-stand for awhile. Idling fine, no warning lights, no roughness. Smoke dissipated then started right back up. Turned it off. Checked the oil glass and it looked low. Opened up the oil cap and you could smell smoke and a burning smell from inside the engine, oil was present though low. Added oil. Restarted. No smoke for a minute or two then white smoke again. Can detect no smell of coolant and reservoir level the same, half way in between min/max.

At a loss as to what this could be.... Head gasket, oil/water pump gasket, oil leak, did I possibly cook the valves etc.?

Any help or advice would be GREATLY appreciated before I take another trip to the dealer.

Thanks to everyone who might respond!