Results 1 to 10 of 10

Thread: Advance Mechanism

Hybrid View

  1. #1
    Registered User
    Join Date
    Mar 2007
    Posts
    414

    Advance Mechanism

    I have read of the sticking advance mechanism causing a hanging idle. How does one determine that the mechanism is free and not sticking? I had a hanging idle on my 78 RS and cleaned the advance mechanism with carb cleaner and then lubed it with some graphite "Lock-Ease". Things seemed OK for a week or so, then the hanging idle came back.

  2. #2
    Administrator 20774's Avatar
    Join Date
    Sep 2005
    Location
    San Antonio, TX
    Posts
    12,894
    A high idle can either be a hanging advance or it can be improperly synched carbs. Have you performed any carb work recently?
    Kurt -- Forum Administrator ---> Resources and Links Thread <---
    '78 R100/7 & '69 R69S & '52 R25/2
    mine-ineye-deatheah-pielayah-jooa-kalayus. oolah-minane-hay-meeriah-kal-oyus-algay-a-thaykin', buddy!

  3. #3
    Registered User
    Join Date
    Mar 2007
    Posts
    414
    I rebuilt the carbs two years ago under the watchful eye of a certified BMW wrench. I did not run the bike until about a month ago and put in non alcholhol gas. I did the intial shop syncs, verfying that the butterflies were opening at the same instant. Mixture screws were set at 1-1/2 turns out. When I did the start up, it did not want to idle and I ended up moving the idle speed stop screws about 4 turns to get the idle to around 1000rpm. Then I took a test ride and the bike ran fine. Got back home and checked the idle speed on each cylinder by alternately pulling the plug wires off (yes, I grounded them to dump the spark). Got th where I had equal idle around 600-700 rpm on each cylinder and 1000 rpm with both. Took another ride, maybe 4 miles and when I got home, the idle was up around 2000. Loaded the engine by easing the clutch out and the idle settled back to 1000 rpm. So, now l you know.

  4. #4
    Administrator 20774's Avatar
    Join Date
    Sep 2005
    Location
    San Antonio, TX
    Posts
    12,894
    Hopefully that first test ride was 15-20 minutes in order to fully warm up the engine before synching the carbs. Have you checked for vacuum leaks at the carb to head sleeves?
    Kurt -- Forum Administrator ---> Resources and Links Thread <---
    '78 R100/7 & '69 R69S & '52 R25/2
    mine-ineye-deatheah-pielayah-jooa-kalayus. oolah-minane-hay-meeriah-kal-oyus-algay-a-thaykin', buddy!

  5. #5
    Registered User
    Join Date
    Mar 2007
    Posts
    414
    Yes, it was about a 15 minute ride on county roads. I have not checked for vacuum leaks.

  6. #6
    Registered User
    Join Date
    May 2012
    Location
    VA
    Posts
    248
    If you have an induction timing light, or want to get one, the advance mechanism can be checked. Both Haynes and Clymer manuals describe checking the advance mechanism operation using a timing light. A Haynes or Clymer manual (and preferably both) have detailed step-by-step instructions. Some details are explained more or differently in either manual. Good luck!


    p.s. These airhead engines are not difficult to diagnose and get running well. However, diagnosing any engine problem requires attention to detail and being meticulous. Skipping steps and shortcuts - especially without the guidance of experience - is a recipe for frustration and spending extra time and money. Similarly, trying to work on these motorcycles without a decent manual is a bad idea.
    Stan

    AH# 13238

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •