Results 1 to 3 of 3

Thread: 93 K1100LT Radio Remote ?

  1. #1
    Registered User
    Join Date
    Jan 2009
    Posts
    4

    93 K1100LT Radio Remote ?

    I have 93 K1100LT and the radio remote quit. I've replaced it, the mount the radio slides into and checked wiring, the red led sometimes will come on but still doesn't work when it does. Please help, Thanks

  2. #2
    Motomark motomark's Avatar
    Join Date
    Jul 2007
    Location
    Clyde N.C.
    Posts
    47
    If you interupted the power supply to the radio at any time while you were replacing the remote you will have to reset the security code.Once code is reentered radio should operate normally.
    Good Luck
    Mark

    1971 R75/5,1990 K75RT,1994 K75,1999 KLR

  3. #3
    Registered User kioolt's Avatar
    Join Date
    Apr 2003
    Location
    Maryland
    Posts
    382
    I don't know what your problem is with your remote but I can give you a little information that may help you decide. The remote on your bike is nothing complicated. It is simply several pushbuttons. The only electronic part in it is the red led. Everything else is just pushbuttons. I can't recall the exact wiring for one of these remotes but if you have an ohmmeter you should be able to tell if the switches are working.
    2004 R1150RT 151,500 miles , 1991 K100LT 128,000 miles, 1982 R100RT 106,900 miles
    Total 386,400 BMW miles
    AMA,BMWRA,BMWMOA
    The cheapest thing on a BMW is the nut that connects the handlebars to the seat.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •