A few weeks ago, my wife's 2009 F650GS wouldn't start after a lunch about 150 miles from home. Since the bike is now out of warranty, I had to find a trailer to tow it to the nearest dealer about another 110 miles away. The dealer replaced the fuel pressure sensor, fuel injectors and fuel pump (parts were "generously" provided by Motorrad, but we had to pay for installation). The bike started well when I picked it up, but on a ride of about another 100 miles a few days later (yesterday), the bike started up but idled roughly. We immediately returned home and this afernoon when I tried to start the bike, it exhibited the same problem, i.e., it would crank, but wouldn't fire up. If I open the throttle, it will crank faster, but still won't fire. Any one have an idea what the problem could be??

Part of my problem is that there is no BMW dealer in Wyoming, so I will have to borrow a trailer again to tow the bike to the nearest dealer in Colorado who worked on it the first time, but I would like to know if there is something I can say to the mechanics to get this thing fixed. I know there are a plethora of problems surrounding the fuel delivery components because I have had the fuel injectors replaced twice on my 2010 F650GS and I suspect the problem was starting to show up on a 2009 R1200GS that I sold, which I feel bad about because I didn't realize the injectors were experiencing early failure, otherwise, I would have had the problem corrected before I sold the R12GS. I thought it was just a bad tankful of gas that was causing the problem. The bike was bought by a Canadian and I hope Motorrad Canada honored the warranty, if in fact the injectors were bad.

Any advice about other potential problems that could be causing the failure to fire would be greatly appreciated.

Thanks