Results 1 to 15 of 17

Thread: r90 Rear Brake Light - Always on

Hybrid View

  1. #1
    Registered User
    Join Date
    Jul 2012
    Location
    Toronto
    Posts
    17

    Question r90 Rear Brake Light - Always on

    My brake light indicator came on when I was riding home last night, checked the brake light and it is constantly on - as though I'm always braking.

    I did a little searching to see what was wrong, I pulled the lead off of the brake light switch on the main cylinder - the rear brake light is still on.

    What should I do to trouble shoot this further?

  2. #2
    Registered User mneblett's Avatar
    Join Date
    Nov 2005
    Location
    Fairfax, VA
    Posts
    1,729
    Check the operation of the rear brake switch -- behind the right passenger footpeg plate -- and the wires from the switch back to the bike harness.

    Next, check the fluid level in the front master cylinder reservoir to make sure it is not too low, and then trace the wiring from the reservoir cap and the front brake switch back up -- look for abraded harness/wires and shorts to ground and/or between the reseroir cap and brake switch wires.

    Next place to look is inside the headlight bucket to see whether any of the wires plugged into the distribution board are shorted/fallen off their spades.

    Let us know what you find.
    Mark Neblett
    Fairfax, VA
    #32806

  3. #3
    Registered User
    Join Date
    Jul 2012
    Location
    Toronto
    Posts
    17

    Still the same

    Thanks for the quick response - just got home and have checked some things out!

    took both wires off of the rear brake switch - brake light is still at its brightest. *I touched those two leads together and it stayed the same - still at brightest.

    Checked all the wires leading around the bike, to rear housing, to headlight bucket, to master cylinder, they all look good.

    Fluid in cylinder is good - checked the leads, they operate properly - brake indicator light goes on at the instrument panel when the float is activated

    The brake light indicator is not on when I start it, it does flicker sometimes when riding (could just be the master cylinder float?)

    All the connections in the housing and tail light look good.

    I'm at a loss, don't know what to do!

    Kevin
    R90/6 - 1976

  4. #4
    Registered User
    Join Date
    May 2012
    Location
    VA
    Posts
    248
    When that happened to mine - it was the brake stop light switch (Part# 61 31 1 244 334) that failed 'on'. The tank has to be removed to access the switch. Simply unplug one of the two wires from the master cylinder pressure switch and see if that fixes the problem. If so, you need a new switch. Good luck!
    Stan

    AH# 13238

  5. #5
    Registered User
    Join Date
    Jul 2012
    Location
    Toronto
    Posts
    17

    Should have mention this

    Hi Stan,

    I checked that too, pulled one of the wires off and the rear brake light didn't change at all.

    Kevin
    R90/6 - 1976

  6. #6
    Registered User
    Join Date
    Jul 2012
    Location
    Toronto
    Posts
    17

    Question Short

    Does this mean I definitely have a short in the system and I'm jut not seeing it?

    Kevin
    R90/6 - 1976

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •