Page 1 of 3 1 2 3 LastLast
Results 1 to 15 of 38

Thread: Garmin Updates- Cruel Hoax?

  1. #1
    Out There Somewhere bmwrider88's Avatar
    Join Date
    Apr 2008
    Location
    Harrisburg, PA
    Posts
    957

    Garmin Updates- Cruel Hoax?

    SO...

    I FINALLY bought a GPS, mostly for the car- a Nuvi 1450 LMT. I figured it's an inexpensive way to get to know the technology, to get my feet wet, as it were.
    After having the thing a couple months, I thought I'd plug it into my PC today to get some updates- what with them being "free for life" and all...

    What a joke it is. First off, my PC won't recognize the device. It's been plugged in all day, and I got nothing, nada, zip...

    or perhaps less.

    I've tried it three ways from Sunday and still nothing. OK maybe I'm not the most tech-savvy person in the world, but I can hold my own typically.

    WTF?

  2. #2
    Debbie's Servant Lee's Avatar
    Join Date
    May 2003
    Location
    SW Iowa
    Posts
    1,526
    Quote Originally Posted by bmwrider88 View Post
    SO...

    I FINALLY bought a GPS, mostly for the car- a Nuvi 1450 LMT. I figured it's an inexpensive way to get to know the technology, to get my feet wet, as it were.
    After having the thing a couple months, I thought I'd plug it into my PC today to get some updates- what with them being "free for life" and all...

    What a joke it is. First off, my PC won't recognize the device. It's been plugged in all day, and I got nothing, nada, zip...

    or perhaps less.

    I've tried it three ways from Sunday and still nothing. OK maybe I'm not the most tech-savvy person in the world, but I can hold my own typically.

    WTF?
    I have one USB cable that does not work with my Nuvi. Have you tried more than one USB cable?
    Lee 2011 K1300S
    MOA # 30878
    Past BMW Bikes, 2003 K1200RS, 1991 K75S, 1987 K75T, 1984 R100RT

  3. #3
    Registered User Firenailer's Avatar
    Join Date
    Feb 2010
    Location
    Westchester, N.Y.
    Posts
    306
    I've had good luck so far with the updates. Garmin is a really good Company, if you're still having a problem contact them and they will walk you through it. A Tech will probably stay on the phone with you until you get it to work!
    Ride Safe,
    Bob
    '12 R1200RT

  4. #4
    Cam Killer marchyman's Avatar
    Join Date
    Jun 2008
    Location
    SF Bay Area
    Posts
    3,492
    Quote Originally Posted by bmwrider88 View Post
    What a joke it is. First off, my PC won't recognize the device. It's been plugged in all day, and I got nothing, nada, zip...
    Did you go here and check for map updates? Some units require some kind of driver to talk to the GPS. It's semi-automagic when you go through the garmin web site. It least it was when I updated the maps on my wife's GPS. Also, there is a link on that page to a PDF that discusses map updates.

  5. #5
    Out There Somewhere bmwrider88's Avatar
    Join Date
    Apr 2008
    Location
    Harrisburg, PA
    Posts
    957
    Quote Originally Posted by Lee View Post
    I have one USB cable that does not work with my Nuvi. Have you tried more than one USB cable?
    Nope- just the one that came with my GPS.

  6. #6
    Outlander Omega Man's Avatar
    Join Date
    Jan 2010
    Location
    Mansfield,MA
    Posts
    6,585
    There are quite a few good threads in this Best of Forum -might help.
    As this will do better in the Gear section, I'll give it a shove over. Gary
    "Well they say.. time loves a hero but only time will tell.. If he's real, he's a legend from heaven If he ain't he was sent here from hell" Lowell George
    2009 F800GS 1994 TW200
    Part of the Forum Threadside Assistance Program

  7. #7
    Out There Somewhere bmwrider88's Avatar
    Join Date
    Apr 2008
    Location
    Harrisburg, PA
    Posts
    957
    Quote Originally Posted by marchyman View Post
    Did you go here and check for map updates? Some units require some kind of driver to talk to the GPS. It's semi-automagic when you go through the garmin web site. It least it was when I updated the maps on my wife's GPS. Also, there is a link on that page to a PDF that discusses map updates.
    I tried that route- and every angle I could find. Canme at it about 5 different ways, and downloaded all the updaters and whatnot. Never got the site to recognize my device- probably the biggest problem. Certainly, it's the first hurdle to over come. Maybe I'll look around in my closet to see if I have any old cables with the mini USB connector that will fit my GPS, camera leftovers or whatever, and try that. I'll also try to upload any software I can find. I tried to upload a thing listed as "for Windows" but no luck-

  8. #8
    Registered User WalterK75's Avatar
    Join Date
    Feb 2009
    Location
    Mississauga, Ontario
    Posts
    567
    Is the device turned on? Don't ask why I ask as it's another learn by experience.
    Walter

    All government, of course, is against liberty.
    H. L. Mencken

  9. #9
    Tame Racing Driver Stig's Avatar
    Join Date
    Dec 2009
    Location
    Hudson Valley, NY
    Posts
    262
    Perhaps try using another USB port. Some of my devices are port sensitive for some unknown reason.
    Craig
    New York's Hudson Valley Region
    2009 R1200RT
    MOA #146131 IBA #55715

  10. #10
    A bozo on the bus deilenberger's Avatar
    Join Date
    Mar 2003
    Location
    Spring Lake NJ, USA
    Posts
    7,748
    Just a FWIW. Older operating systems such as Windows XP often require that you download and install a driver before connecting the device - or the operating system will not recognize it. And some hardware may never find the device or even know it's been plugged in if the driver isn't preinstalled. The Garmin website should have a driver for your OS.. and some info on installing it.

    It's mostly newer OS's (Vista, Windows7) that automatically detect the new device and go looking for the drivers.
    Don Eilenberger http://www.eilenberger.net
    Spring Lk Heights NJ NJ Shore BMW Riders New Sweden BMW Riders
    '07 R1200R (current ride) and some bimmers.. and a Porsche

  11. #11
    Registered User arthurdent's Avatar
    Join Date
    Sep 2005
    Location
    Central Nebraska
    Posts
    348

    Try another forum?

    Have you tried geocaching.org? Their forums are geared to another purpose, but a lot of good resources available.

  12. #12
    Out There Somewhere bmwrider88's Avatar
    Join Date
    Apr 2008
    Location
    Harrisburg, PA
    Posts
    957
    Currently installing Base Camp, updated the NET Framework.

    Yes the GPS IS on, or so I assume since it's al lit up & I was navigating around on it to see if I could prompt an update through its internal "systems" or some such.... it turned itself immediately on when I jacked it into the USB port. Oh, tried a couple different USB ports already, too....

    Running Windows service pack 3, but I'm using Firefox. Should I be doing this in Internet Explorer? Or is there a Firefox update I need to know about or add-on, or whatever that might facilitate the interface?

  13. #13
    Dum vivimus vivamus ted's Avatar
    Join Date
    Mar 2003
    Posts
    2,589
    Call Garmin, they are quite helpful but can be a bit erratic of late so if you get someone who does not seem so knowledgeable just hang up and call back. By the way, the cheapest place for high quality cables is monoprice.com - I always over order because they are so inexpensive and have spares filling up drawers. It's a bad habit
    Ted
    "A good stick is a good reason"
    1994 K75RT
    Moto Pages

  14. #14
    Debbie's Servant Lee's Avatar
    Join Date
    May 2003
    Location
    SW Iowa
    Posts
    1,526
    Quote Originally Posted by deilenberger View Post
    Just a FWIW. Older operating systems such as Windows XP often require that you download and install a driver before connecting the device - or the operating system will not recognize it.
    I have Windows XP on my desktop and I'm pretty sure I had to download a driver before I proceded with any updates.
    Lee 2011 K1300S
    MOA # 30878
    Past BMW Bikes, 2003 K1200RS, 1991 K75S, 1987 K75T, 1984 R100RT

  15. #15
    Debbie's Servant Lee's Avatar
    Join Date
    May 2003
    Location
    SW Iowa
    Posts
    1,526
    Quote Originally Posted by bmwrider88 View Post
    Running Windows service pack 3,
    Do you have Wndows XP, Vista, or 7?
    Lee 2011 K1300S
    MOA # 30878
    Past BMW Bikes, 2003 K1200RS, 1991 K75S, 1987 K75T, 1984 R100RT

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •