Results 1 to 3 of 3

Thread: Once again, no ON.

  1. #1
    I am the .45% DBCasey's Avatar
    Join Date
    Sep 2010
    Location
    Frankfort, Kentucky
    Posts
    175

    Angry Once again, no ON.

    I just don't understand it.

    No Owners News. Again. Last month it was here by the 10th, but no show Dec, Jan and now this month. The ones that do show up are usually mangled. My friend across town gets his by the 5th every month, and in great shape. I just can't figure this one out. I've asked my mailman, and he says the magazines are already torn when he gets them.

    I appreciate that MOA HQ is addressing this problem, and for sending me another copy. I just hope they can figure out what's causing the hold up and the damage issues.

    I don't think I'm the only one having this problem.

    Better late than never, I guess!

    DC
    Thank a teacher if you can read this, thank a veteran that it's in English.

    D.B.Casey-MSF#133889
    2011 RT

  2. #2
    not so retired henzilla's Avatar
    Join Date
    Sep 2006
    Location
    between SanAntone & the Weird Place, TX
    Posts
    5,923
    Moving to Campfire where this is discussed here:

    http://www.bmwmoa.org/forum/showthread.php?t=58274
    Steve Henson
    SABMWRA MOA Club#62's Flat Fixer/ current forum moderator
    It's not the breaths you take, but the moments that take your breath away-D.Dillon/G. Strait

  3. #3
    Registered User Anyname's Avatar
    Join Date
    Jun 2007
    Location
    Portsmouth, NH
    Posts
    731
    I'm gonna go out on a limb and speculate that the Postal Service randomly or loses trashes a percentage of items entrusted to it for delivery. I'll further speculate that the BMWMOA isn't going to have much luck fixing the Postal Services issues.
    BMW R bike rider, horizontally opposed to everything...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •