Page 2 of 19 FirstFirst 1 2 3 4 12 ... LastLast
Results 16 to 30 of 275

Thread: 2004 R1150RT Wideband O2 Sensors

  1. #16
    John. jstrube's Avatar
    Join Date
    Nov 2009
    Location
    Atwater, CA
    Posts
    964
    What part of the O2 are you looking for? I may have a dead one from a car around here. The thread size is usually the same on all of them, or are you looking for the plug end? Those may be similar as well...

    It might not be completely dead, just sluggish though. What is your plan with the dead one?
    John.

  2. #17
    Registered User roger 04 rt's Avatar
    Join Date
    Oct 2011
    Location
    Massachusetts
    Posts
    1,210
    Quote Originally Posted by JStrube View Post
    What part of the O2 are you looking for? I may have a dead one from a car around here. The thread size is usually the same on all of them, or are you looking for the plug end? Those may be similar as well...

    It might not be completely dead, just sluggish though. What is your plan with the dead one?
    Thanks. Looking for the connector. It's a four wire. But I don't know its config. I'll use the connector and pigtail to attach 2 wires from the LC-1 and two wires to a resistor to simulate the heater load to the Motronic.

  3. #18
    Registered User
    Join Date
    May 2007
    Location
    Western NY
    Posts
    249
    Quote Originally Posted by Red100RT View Post
    I think the latter R1200's do. I looked at a 2011 R1200R that did last summer at a dealer whilst I was dreaming. Had a sensor before and after.
    I think the "sensor" after the cat is the exhaust flap.
    Karl
    2007 R1200ST

  4. #19
    Jammess jammess's Avatar
    Join Date
    Aug 2005
    Location
    Florence, OR.
    Posts
    584
    Quote Originally Posted by kthutchinson View Post
    I think the "sensor" after the cat is the exhaust flap.
    You're probably right in that there isn't a sensor after the cat. I maybe am thinking about my Mustang. Getting old. I think the R1200R has two sensors one for each side ahead of the cat. Going to Boise and drool some more so will look again. Could have sworn I saw a sensor after the cat but probably mistaken. Sorry for bad info.
    Jammess

  5. #20
    Day Dreaming ... happy wanderer's Avatar
    Join Date
    Mar 2010
    Location
    Vancouver, B.C. Canada
    Posts
    1,814
    Quote Originally Posted by Red100RT View Post
    You're probably right in that there isn't a sensor after the cat. I maybe am thinking about my Mustang. Getting old. I think the R1200R has two sensors one for each side ahead of the cat. Going to Boise and drool some more so will look again. Could have sworn I saw a sensor after the cat but probably mistaken. Sorry for bad info.
    The O2 sensors on the R1200 are in each header pipe just aft of the down bend.
    Item number 2 below. Don't see a "flap" in the fiche. On my '00 RT the O2 sensor is just in front of the cataclysmic perverter. (Under my right foot eh?)

    MJM - BeeCeeBeemers Motorcycle Club Vancouver B.C.
    '81 R80G/S, '82 R100RS, '00 R1100RT

  6. #21
    Jammess jammess's Avatar
    Join Date
    Aug 2005
    Location
    Florence, OR.
    Posts
    584
    Yes, the sensor on my '04RT is just ahead of the cat probably same as yours. I looked at the same diagram of the exhaust system on oemparts. Hey, what can I say? It was a year ago I looked at that new R1200R and I could have sworn I saw a sensor after the cat. This wouldn't effect my decision to buy one or not. No way am I ever going to buy another new beemer or any other new mc for that matter. Just to much dinero or should I say Loonie, eh.
    Jammess

  7. #22
    Registered User roger 04 rt's Avatar
    Join Date
    Oct 2011
    Location
    Massachusetts
    Posts
    1,210

    Highway Trip

    Made the highway run yesterday. Data below.

    Data Points: 2,100

    Driving RPM Range: 3,700 to 5,000 (roughly)
    Injectors Fully Off: 3.3% of trip

    Closed Loop O2: 47% of trip, up to 80% in steady throttle cruise

    I observed two new things from this trip.

    1. The highest correlation for closed loop operation is when the TPS (Throttle position) is steady. (I guess that shouldn't be a surprise.)

    2. The Motronic will go into Closed Loop mode while the bike is accelerating through the gears. As each new gear was engaged, the Motronic started in Open Loop operation (richest mixture) but would go Closed Loop (leaner mixture) while accelerating. This surprised me. When the bike is cold, it remains Open Loop. My thinking is this is why the motorcycle seems more driveable cold vs hot.

    (I can only post one photo at a time so the shifting charts will follow.)

    In the chart below (RPM, TPS and Lambda On/Off) you can see the effect of accelerating through a few gears in traffic on the left side (to 5th gear) of the chart (and dealing with changes in traffic speed). On the right half of the chart (to 6th gear), the bike is in "throttle-locked" cruise, more or less. It is in closed loop a lot of the time.

    If anyone has an old and/or dead R1150RT O2 Sensor, please PM me. I would like to purchase it for the connector so that I can build a Wide Band replacement system. Thanks.
    Attached Images Attached Images
    Last edited by Roger 04 RT; 12-06-2011 at 07:01 PM.

  8. #23
    Registered User roger 04 rt's Avatar
    Join Date
    Oct 2011
    Location
    Massachusetts
    Posts
    1,210
    Cold Engine Takeoff, bike feels strong, no sense of lag or surge. Lambda sensor is Open Loop.
    Attached Images Attached Images

  9. #24
    Registered User roger 04 rt's Avatar
    Join Date
    Oct 2011
    Location
    Massachusetts
    Posts
    1,210
    Warm Engine Takeoff, bike feels okay but slightly hesitant before shift to next higher gear. Lambda sensor goes Closed Loop (lean) in middle of acceleration. (Numbered points are: Throttle Open #1 &4, Clutch Engaged #2 & 5, Lambda Closed Loop #3 & 6.)
    Attached Images Attached Images
    Last edited by Roger 04 RT; 12-06-2011 at 09:07 PM.

  10. #25
    Registered User roger 04 rt's Avatar
    Join Date
    Oct 2011
    Location
    Massachusetts
    Posts
    1,210
    Warm Engine Highway Acceleration, bike feels good but note that Motronic goes Closed Loop (lean mixture) in middle of acceleration. (Numbered points are: Throttle Open #1, Acceleration #2, Lambda Closed Loop #3.)

    I am surprised at the times during acceleration at low and high speeds/RPMs that the Motronic chooses to go Closed Loop.

    I've ordered an Innovative Motorsports LC-1 and will see what the feel of a richer Closed Loop AFR is. I expect to notice it most under warm engine start-off conditions under 3,500 RPM.
    Attached Images Attached Images
    Last edited by Roger 04 RT; 12-06-2011 at 09:07 PM.

  11. #26
    Registered User roger 04 rt's Avatar
    Join Date
    Oct 2011
    Location
    Massachusetts
    Posts
    1,210

    Grounding Question

    Yesterday I pulled the tupperware and exhaust, removed the stock O2 and dropped in the wideband LC-1 O2 sensor. Also scoped out how and where I will locate and connect the LC-1 "computer". It looks like it will fit nicely under the tank strapped to the frame, in front of the ABS. Will add a photo later.

    There are multiple grounds to connect. Does anyone have experience with the best location for adding new ground wires?

    Also installing Beemerboneyard metal QDs at this time since the tank is off.

    Once installed my plan is:

    1) Ride with the O2 sensor function NOT connected to the Motronic to get baseline data ON AFR/Lambda.

    2) Attach virtual-narrow-band O2 function with Lambda=1 to verify that it runs correctly and stays Closed Loop as per the stock O2 sensor.

    3) Adjust Lambda upward and downward in small steps to measure its effect on warmed-up driveability.

    RB

  12. #27
    Registered User roger 04 rt's Avatar
    Join Date
    Oct 2011
    Location
    Massachusetts
    Posts
    1,210

    LC-1 Installed

    Yesterday I finished installing the Innovate Motorsports LC-1 Wideband O2 Controller on my 2004 R1150RT. Before describing the project and my first test ride impressions a couple points:

    --When the valves are adjusted, idle set and the throttle bodies are balanced my 1150RT runs pretty well.
    --My preference is that the motorcycle is as near stock as possible, maintaining EVAP canister and Catalytic converter.
    --BMW and Bosch (Motronic, O2 sensor, ABS) design well and know more about these systems than I ever could.
    --The aircraft that I flew for a couple decades had three main performance modes: Full Rich (takeoff and climb), Best Power (fastest cruise, AFR< 14) and Best Economy (greatest range, AFR > 15). Although all modes were "smooth", if you over-leaned Best Economy the engine would start to stumble and eventually ping.

    --Ethanol fuel: The 2004 RT uses Open Loop fueling tables that were designed for gasoline with a stoichiometric AFR of 14.7:1. In the Northeast US, gasoline with up to 10% ethanol is about all that's available, which has a 14.1:1 AFR. This suggests that the stock Open Loop fueling tables run about 4% leaner than the BMW/Bosch designers planned for. (In Closed Loop operation when the O2 sensor is used for control it automatically corrects for the E10 fuel.)

    --My '04 RT feels strong while the engine is cold. After warming up, the motor seems reigned-in a bit from 2,000 rpm to 4,000 rpm (and reminds me a lot of how my plane felt with a too-lean mixture). After warming up the Motronic allows Closed Loop operation with the O2 sensor which means the AFR (in gasoline terms) is toggling between an AFR in the low 14s to an AFR in the low 15s. And since the cylinders are independent of one another, one cylinder is bound to be even leaner than the other.

    My project goals:
    1) Open Loop: Richen fueling tables to compensate for gasoline with Ethanol added. For this I've used a BoosterPlug which claims 6% richer mixtures; and ethanol fuel is about 4% leaner so I'm guessing about a 2% gain richer mixture overall.)

    2) Closed Loop: Richen the stoichiometric target by the smallest amount needed to remove the sense of leanness between 2,000 and 4000 rpm. The Innovate Motorsports LC-1 provides a programmable Narrow Band output to the bike's Motronic ECU input.

    Project:
    LC-1 Kit: Bosch Wideband O2 sensor, LC-1 Controller, Cables, Programming Software, Serial Bus programming input.
    Also purchased: PC Serial Bus to USB Converter (since none of my computers have serial inputs)

    1. Pull the fairings, remove the fuel tank (replaced QDs at same time).
    2. Drop the exhaust, remove stock Narrow Band O2 sensor, install Wideband O2 sensor.
    3. Install LC-1 controller on right side of bike, under tank on frame, near alternator.
    4. Connect Wideband O2 to LC-1, routing cable using same path as stock O2 sensor.
    5. Route LC-1 cables to left-hand side of bike, along frame, and make connections to power, ground, AFR meter (part of LC-1).
    6. Route LC-1 programming cables to area under seat behind electrical box.
    7. Connect LC-1 Narrow Band output to Motronic by cutting and splicing into the original O2 sensor leads.
    8. Leave O2 heater wires connected to the stock Narrow Band sensor, temporarily, until I can figure out what the Motronic needs to "see" in order to enable Closed Loop and not create a fault code. Tie wrap O2 sensor to frame.
    9. Program closed loop AFR target to 14.2 which was a guess about where to start.
    10. Start the motorcycle, attach the GS-911, let it warm up, confirm Closed Loop operation and make sure there were no Fault Codes in the Motronic. EVERYTHING WORKED! (Photo below shows #1) AFR switch points, and #2) that the bike entered Closed Loop after warming up.)

    The installation took about 6 hours spread over a few days. Someone experiencde could do it faster but it was the first time I'd pulled the tank and exhaust. I got out for a test ride late yesterday.

    Riding Impressions:
    The course was over winding, hilly, straight and flat roads for about an hour. I am truly excited by the first results. Knowing that I'm looking for a positive outcome I wouldn't blame you for being skeptical. I haven't collected data yet to back up my impressions. But I'm not selling anything, just trying to enjoy my bike more. Here are some observations.

    --No hesitation, no feeling of being reigned-in or surging. No popping, pinging or backfiring. In brief, no negatives.
    --Very smooth acceleration in every gear at high and low RPMs.
    --Good roll on throttle response at high and low RPMs.
    --Very good cruise at low RPMs (2,500 to 4,000). 5th gear was a pleasure at 40 MPH or so. 6th gear, from memory, was easy at 50.
    --Smooth at high RPMs.
    --Warmed-up bike using Closed Loop modes feels just like the cold engine--strong and smooth.

    Still to be done:
    --Clean up wiring
    --Figure out what to do about Motronic heater wires (cut or add a resistor)
    --Try many more combinations of Closed Loop AFR settings
    --Carefully monitor Motronic operation with GS-911 (no error codes so far)
    --Get an exhaust gas analysis after settling on an AFR.

    I'm not sure how much I can get done before the snow starts here in MA. When it does start snowing, the bike will get opened up for a spline lube.
    Attached Images Attached Images
    Last edited by Roger 04 RT; 12-18-2011 at 03:47 AM.

  13. #28
    Registered User roger 04 rt's Avatar
    Join Date
    Oct 2011
    Location
    Massachusetts
    Posts
    1,210
    Over the last two days I've put a few hours on the bike. I have to say, that the slight downward shift of Closed Loop Lambda (AFR) from 1.000 to 0.965, has made a remarkable change in smoothness and low-end power. There has not been any sense of hesitation, in fact quite the opposite. I'm now running RPMs between 2500 and 3500 around town, even in 5th gear.

    As far as the Motronic ECU is concerned the data looks like this:

    Total data points: 4,000
    Percent Closed Loop: 45% (same as before for the local conditions)
    Average Closed Loop Lambda Voltage: 410 mV (right where expected, indicating good loop closing)

    The new shift plots are looking the same as the earlier stock sensor plots. The big difference being the improved performance and the AFR meter reading 14.2:1 +/-. The above also indicates that the Motronic has been "convinced" to accept the programmable O2 setting and doesn't know that I've richened Closed Loop Lambda.

    The next tests will be on the highway.

    There are several variables still to be tuned:

    High Lambda Voltage: (800 mV to 1V)
    Low Lambda Voltage: (0V to 200mV)
    Low Lambda Value: (how far below the 0.965 mid-point)
    High Lambda Value: (how much above the 0.965 mid-point)
    Target Lambda: (is there a better target that 0.965, implied AFR 14.2)

    Filter Sensor inputs?
    Monitor Sensor waveform.

    In spite of what needs to be evaluated still, it looks to me like a slightly lower Lambda target (richer AFR) makes a MUCH smoother bike.

    Will post up some charts later.

  14. #29
    Registered User roger 04 rt's Avatar
    Join Date
    Oct 2011
    Location
    Massachusetts
    Posts
    1,210

    Data Plots from AFR 14.2

    Here are some plots of several thousand data points acquired while running at 14.2 Air Fuel Ratio (AFR). The key observation is that the Motronic is operating normally, unaware that it has been spoofed to run at Lambda=0.965 which is an equivalent gasoline AFR of 14.2.

    This an acceleration through a couple of gears with a warm engine. Notice that just like the earlier chart (a few posts back), the Motronic goes into closed loop while the RPM is accelerating. The Motronic doesn't know the Closed Loop AFR is 14.2, but for the rider (me) the engine feels much stronger and smoother because the AFR is richer.




    The next two charts show a before (14.7 AFR with Stock Narrow Band O2 Sensor) and after (14.2 AFR with Wideband O2 Sensor and LC-1 connected to the Motronic in place of the Stock Sensor). Although the shapes of the curves are different due to how I have set up the hi/low transitions (something I will continue to experiment with) the key takeaway is that the Mean (average) and Median voltages are nearly identical (about 20 mV different). This suggests that the Motronic is controlling Closed Loop operation and is satisfied that it is in charge, producing the same average Lambda in Closed Loop.

    Stock O2 Sensor


    Wideband O2 Sensor


    Next I will get some highway riding time in.

  15. #30
    Registered User roger 04 rt's Avatar
    Join Date
    Oct 2011
    Location
    Massachusetts
    Posts
    1,210
    For those interested in the most arcane aspects of this project (probably no one but me ), might like to try it or who might offer some insight:

    --Both the heater and the sensor are isolated from the case (meaning they are not grounded to the exhaust) in this four wire O2 probe.

    --The wire called signal ground seems to have a 100 ohm source impedance (more to be confirmed), and the open circuit voltage is 140 mV. Since the sensor is isolated from the case, this strongly suggests that the entire sensor signal is offset by 140 mV. I have read that the reason for this offset is to allow shorted and open leads to be detected by the ECU--makes sense. Right now I may have the +Signal going negative relative to the -Signal.

    --I have also read that the ECU builds closed loop adaption tables so I should be doing a full reset of the ECU each time I change an LC-1 parameter.

    --This signal + side seems, from research, to be routed to a dual comparator circuit that creates a +/- 25mV hysteresis window.

    Although things are working really well, I am not convinced I am getting a good rich/lean toggle yet so I will probably go and get an oscilloscope so that I can look into all this with a bit more certainty.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •