Results 1 to 5 of 5

Thread: RT fog lights stuck on

  1. #1
    Registered Schmoozer irish's Avatar
    Join Date
    Oct 2009
    Location
    Madison, WI
    Posts
    88

    RT fog lights stuck on

    I can't find a similar thread so I'm hoping someone has some ideas about this. I normally ride with my fog lights on all the time. Last week I tried to turn them off while riding to see how my new low beam was working (I installed an Osram Rallye 65W) and when I toggled the switch to "off" the fog lights and fog light indicator light stayed on. I toggled it on and off a few times and eventually it turned off.

    Then a few days ago my bike was parked with the ignition off and a good Samaritan told me that my lights were on. The fog lights were stuck on again, as was the indicator light! All the other lights were off and the ignition was in the locked position. I toggled the fog light switch back and forth which did nothing. Then I turned the ignition on and hit the start button briefly, just enough to turn the engine over but not start it. After that I was able to shut off the fog lights with the toggle switch.

    I have not seen other threads with fog lights stuck on. If the problem were with the ignition circuit I would think it would affect all the lights, not just the fogs. For electrical mods on my bike I have a Diamondstar headlight modulator and PIAA 1100x driving lights, but those have both been on the bike for over a year with no issues. I have made no modifications to the fog lights.

    I have an appointment with my BMW dealer on Wednesday since I have to get this fixed before a trip next weekend. Does anyone have any thoughts on where the probem might be or how to fix it?
    02 R1150RT

  2. #2
    MOA #24991 Pauls1150's Avatar
    Join Date
    Apr 2008
    Location
    south of Los Angeles
    Posts
    1,520
    My first guess has to be a bad switch; those plastic rockers on the dash are not exactly enduro. Second guess is that there's a wiring short that is essentially bypassing the switch.

  3. #3
    Registered User
    Join Date
    Mar 2007
    Location
    Ambler, PA
    Posts
    132
    There's only 2 possibilities:
    1. the fog light relay is stuck on
    You can prove this is the cause by pulling F10, the fog light fuse, next time the lights are stuck on. If the pulled fuse turns them off, then it was the relay. Easy to test, just swap it with one of the other black relays, like from the horn (but don't risk driving around with a stuck horn, ha ha).


    2. after-market lighting wire is intermittently shorted to your fog light hot wire, which comes from the relay and goes to both lights and the indicator. If you pulled fuse F10 and the lights are still on, then that wire is shorted to a 12v wire someplace. Time to wiggle wires when the problem occurs.

    I haven't exactly heard of this problem, but I have noticed in the last year that when I do (rarely) turn off my fog lights, sometimes they are stuck on, until I toggle the switch a few times, hard. I assume my little-used switch is going bad. But in your case, with the key turned off entirely and the lights still on, that can't be coming through the switch, so your switch is not the culprit.
    --
    Doug Raymond
    R1150RT '02
    Ambler, PA

  4. #4
    Registered Schmoozer irish's Avatar
    Join Date
    Oct 2009
    Location
    Madison, WI
    Posts
    88
    Thanks for the responses. I took it to the dealer today and they could not replicate or diagnose the problem. I can't get it to happen again either. I asked about the relay and they explained that there is one relay that controls all the lights so if the relay were bad you would expect the headlight to be on too, not just the fogs. The checked the switch and connections and dabbed some dielectric grease around so hopefully that takes care of it. If it occurs again and I figure out a solutoin I will post an update.
    02 R1150RT

  5. #5
    Registered Schmoozer irish's Avatar
    Join Date
    Oct 2009
    Location
    Madison, WI
    Posts
    88
    DougRaymond, I should have listened to you and not the dealer. In my last post I mentioned I had taken it to the dealer, I was there for another issue and asked them about the fog lights as well. Since they told me it could not be the relay since the relay controls all the lighting I didn't think about the relay any further and have just been dealing with this in the meantime as a very intermittent issue.

    Fast forward to a week ago, when my fog lights went out and would not turn on. I thought I was dealing with a disconnected ground wire or something and was preparing to dig into the electicals to find it. When I tapped on the lighting relay (the relay farthest to the right side of the bike) sometimes the fog lights would go on, however. This relay is, indeed, only for the fog lights and NOT for all the lights as my dealer had told me. Replacing the relay seems to have fixed the issue. Interestingly, the stock relay is no longer made as far as I can tell and has been replaced by one with a different part number. Wonder if others had issues with them failing.
    02 R1150RT

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •