Results 1 to 4 of 4

Thread: N103 Shield not staying up - FIXED

  1. #1
    Registered User bluegrasspicker's Avatar
    Join Date
    Aug 2006
    Location
    MN
    Posts
    299

    N103 Shield not staying up - FIXED

    I had a problem with my shield not staying up in even moderate winds.
    If you have this problem here is how I fixed mine with two small pieces of the fuzzy side of velcro.





    This does not interfere with the shield mechanism, and unlike the photos is nearly invisible.
    Last edited by BluegrassPicker; 06-12-2011 at 12:07 PM.
    Tom Barrie
    http://bluegrasspicker.blogspot.com/
    2012 K1600GTL
    2002 R1150RT (sold)

  2. #2
    Registered User
    Join Date
    Dec 2010
    Location
    Indianapolis
    Posts
    349
    Good tip. I have exactly that problem.

  3. #3
    Rally Rat
    Join Date
    Dec 2005
    Posts
    280

    Good post I have the same problem

    I have been trying to find a solution for my Scorpion EXO700 for over a year. This may be it. I will know tonight.

    Thanks a million. It is nice to know there are still great minds out there.

  4. #4
    Rally Rat
    Join Date
    Dec 2005
    Posts
    280
    I tried the Velcro fix this morning. OMG, a five minute mod and a two year problem is solved. At highway speeds of 80 MPH my Scorpion helmet face shield stayed in the last indent with no issues.

    Thank you, thank you, thank you!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •