Results 1 to 15 of 20

Thread: quick turn signal question

Hybrid View

  1. #1
    new kid
    Join Date
    Nov 2010
    Location
    Athens, GA
    Posts
    106

    quick turn signal question

    ...at least i hope this is a quick one, haha.

    the turn signal indicator light in the instrument cluster has stopped blinking. it blinks once and then stays off whenever i use the turn signal. the turn signals all work fine.

    someone told me once that this means one of the turn signal bulbs is out, or about to go out? i have no idea if thats true though.

    reading through the archives i found alot of people with the light staying on, or coming on erratically or intermittently, but this just blinks once and turns off when i turn the signals on, either direction.

    is it as simple as a bulb about to go out? or is it some kind of relay or connection problem?

  2. #2
    Registered User
    Join Date
    Jun 2003
    Location
    Northern Front Range, CO
    Posts
    6,431
    there is no such thing as "a bulb about to go out". either the filament is good and they work, or the filament is broken, and they don't.
    are your blinkers currently working as intended? if no, that's likely the problem. if yes, then its something else (but i've no idea what)
    Ride Safe, Ride Lots

  3. #3
    new kid
    Join Date
    Nov 2010
    Location
    Athens, GA
    Posts
    106
    haha, yeah thats what i thought when he told me, it doesn't make any sense to have a light "about to go out." but i just wanted to give you all all the "information" i had, haha.

    anyway, yes the blinkers are all working as they should. just the indicator in the cluster blinks once and stays off.

    i suppose i'll dig around a bit and look at the relay and wiring and whatnots. i was just hoping the one blink was a sign of something specific. not a huge deal right now as the blinkers all work, but something to check on when i have some free tinkering time.

  4. #4
    Registered User
    Join Date
    Jun 2003
    Location
    Northern Front Range, CO
    Posts
    6,431
    Quote Originally Posted by apt13 View Post
    . not a huge deal right now as the blinkers all work, but something to check on when i have some free tinkering time.
    yup. jsut remember to cancel your signals once turn completed.
    Ride Safe, Ride Lots

  5. #5
    Unregistered User dduelin's Avatar
    Join Date
    Jan 2008
    Location
    N. FL
    Posts
    211
    If the turn signals all work normally but just the green indicator light works once then goes out you might have a fault where the indicator bulb holder fits into the plastic film "circuit board"inside the intrument pod. The bulb holder has to make a connection at the place where the metal circuit strip has to make a 90 degree turn and the bulb holder contacts scrape away the metal it must make contact with. A bit of corrosion there creates enough resistance not to allow the bulb to work all the time like it used to. If you take the instrument pod apart you might be able to clean the contact area up and fix it or find the metal is just gone where it makes that 90 degree bend. Mine was like this and I rigged up a fix that involved tiny squares of aluminum foil to bridge the broken area. It worked for short periods of time but the real repair is to replace the circuit board which, the last time I checked, was still available. Me, I just got used to looking at the switch in my road/instrument scan so I don't ride too long with a blinker on. I had the pod apart several times for this and for an odometer repair and I wasn't sure how many times the fragile screw holes and plastic tabs that assemble the pod would stay together.
    Dave
    R100
    ST1300

  6. #6
    Russ 78goldie's Avatar
    Join Date
    May 2008
    Location
    Centennial, Colorado
    Posts
    19
    I too am experiencing the intermittent turn signal lamp from proper function and will check for these fixes, but the wildly flucuating volt meter needle alerts me to the turn signal being left on. Almost easier to see than the dim bulb in daylight....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •