Garmin has lowered the price of lifetime maps for Garmin "members".. to about $75 for my BMW-Motorrad-Navigator-III.

I was getting tired of the nag, and since a relative wanted to buy me a Christmas present, I figured this would be a good one - lifetime map updates.

I ordered the update on line, and then hooked up the Navigator-III to the computer. The upgrade process involves checking to make sure you have the GPS, then downloading a LARGE file to your computer, wiping the old map out, then transferring the new map..

The download was estimated at 3-4 hours (it slowed down whenever I did anything else on the web) - I have ADSL - 1.5mb/down, 0.75mb/up.. It ended up taking close to 4 hours. This put the rest of the process way past my bedtime, so I left it going and went to bed, expecting to find things done in the AM.

Imagine my surprise (!) to come down the next morning to a GPS with the "Transferring Data" screen still up, and a computer that had rebooted. Apparently (Vista OS), I had the automatic update from MS settings to allow it to download AND update automatically. And MS's update really didn't care that another process was running, and simply rebooted the computer. This must have happened after the installer deleted the old map (I rebooted the GPS, and all it had left was the BMW dealer map, and the big-highway base map.)

I started up CityNavigator (Garmin's program) to see if I could download the updated maps to the GPS that way. It had the new version of the maps - but after clicking on every US area map, and some Canadian ones, it told me there wasn't room on the GPS (485mb available, 1,300mb needed.)

Apparently - the installer had only partly deleted the old maps..

What to do? I emailed Garmin's tech support, and within about 4 hours had a reply. The reply was - log into their site again, and do the download/install again with the GPS connected to the computer. Since the computer DID have the new maps on it (as seen in CityNavigator) - it wouldn't have to download them again. It would just clear off the GPS, and install them.

Tried it - worked perfect. Took about 1 hour to do.

Thanks to Garmin support for a quick effective and understandable response, and no-thanks to Microsoft for rebooting my PC while a process was running. That setting has now been changed.