Results 1 to 3 of 3

Thread: Gear/Neutral Indicator not working. 05 RT

  1. #1
    IDSECURE
    Guest

    Gear/Neutral Indicator not working. 05 RT

    Hey All,

    Just got my first BMW a couple of weeks ago and have been really enjoying it. I'm new to the forum and look foreword to lot's of farkling. The bike has 24k on it and is in great shape.

    I just had a couple of questions and thought some of you may have had a similar experience. The first one is: My gear indicator/neutral lights stopped working on the way home from our maiden multi day ride last weekend then this morning I went for a trip to the store and it came back to life about half way to the store?

    The only other thought I had was do I need to check and specific nuts, bolt's tolerances that are a known issue on the bike. Like my previous FJR the first things you need to do are lock-tight the saddlebag bolts as they will fall off. Snip the over tightened zip ties under the ignition as they literally pull the wires from the seats in the ignition. Ect.

    Just general 05 RT stuff that I just have no clue on as this my my first!

    Thanks in advance for your thoughts.

    Damon

  2. #2
    Registered User
    Join Date
    Jun 2003
    Location
    Northern Front Range, CO
    Posts
    6,416
    Damon- your 2005 R1200RT is a HEXhead, not an oilhead. posting in the hex forum will net your more/better results.
    Mod- cleanup on aisle 3.
    Ride Safe, Ride Lots

  3. #3
    IDSECURE
    Guest
    Fish,

    My mistake just getting familiar with my surroundings here.

    Off to the Hexhead team!

    Thank You!

    Damon

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •