Results 1 to 4 of 4

Thread: ABS Brakes

  1. #1
    tom9615
    Guest

    ABS Brakes

    I have a 2003 K1200 LT with ABS Brakes. My problem is I get a continuos flashing warning light next to the ABS light sometimes when I first start the bike. Other times the ABS light flashes like it is suppose to and then goes out. Anybody with any idea's of how to fix, could sure use your help. Closest BMW Dealer 4 hours away.

    Thanks for any and all suggestions

    Tom Porath

  2. #2
    2-up and havin' fun sugarhillctd's Avatar
    Join Date
    Oct 2007
    Location
    Just above the Notch, NH
    Posts
    519
    Tom,

    1st- how old is your battery?

    2nd- have you recently let the bike sit for a while without plugging into a charger?


    Many times brick ABS problems are caused by low battery voltage. I have had it happen intermittantly on my K1100RS- the ancestor to your LT- especially during colder weather when starting is harder on the battery and grip heaters &/or heated gear draws more on the electrical system.

    Good luck,
    John
    John & Cathy
    '92 K100RS (gone- '04 R1100S Boxer Cup)
    '12 Suzuki DRZ400
    ("kid's" bikes) '02 Kaw ZX6R- Jen's '07 Duc 800ss- Johnnie's

  3. #3
    Registered User lkchris's Avatar
    Join Date
    Mar 2003
    Location
    Albuquerque, NM
    Posts
    4,804
    Yes, ABS relies on electric motors to function.

    Since ABS is a safety system, it's a safety warning to let you know system voltage may not be enough to operate the system.
    Kent Christensen
    21482
    '12 R1200RT, '02 R1100S, '84 R80G/S

  4. #4
    tom9615
    Guest

    ABS Brakes

    Thanks for the information. Checked battery found ground cable slightly corroded and the positive cable loose. Cleaned and tightened and the flashing light went away.

    Thanks again for the info

    Tom Porath

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •