Results 1 to 11 of 11

Thread: Neutral light always on

  1. #1
    rbleau
    Guest

    Neutral light always on

    Any quick tips for a neutral light always on ? The brightness changes a bit when actually in neutral. On a 1977R100S. thanks in advance / RB

  2. #2
    Administrator 20774's Avatar
    Join Date
    Sep 2005
    Location
    San Antonio, TX
    Posts
    13,248
    Try removing the connector on the neutral switch. Light still on? If not, then the neutral switch has failed. If still on, then there's some other ground point in the circuit that causes the light to go on.
    Kurt -- Forum Administrator ---> Resources and Links Thread <---
    '78 R100/7 & '69 R69S & '52 R25/2
    mine-ineye-deatheah-pielayah-jooa-kalayus. oolah-minane-hay-meeriah-kal-oyus-algay-a-thaykin', buddy!

  3. #3
    . AntonLargiader's Avatar
    Join Date
    Jul 2004
    Location
    Charlottesville, VA
    Posts
    1,377
    On some early bikes (I forget which ones) you need to use two of the washers to make the switch work right. It is a NC switch that opens by extending into a recess in the 3-4 shift cam. In your case it isn't able to extend far enough to open. Try a second washer under it.

    Or maybe it's something else entirely.
    Anton Largiader 72724
    largiader.com bmwra.org

  4. #4
    rbleau
    Guest

    Thanks

    Thanks 20774 and Anton / will troubleshoot tomorrow - it is rest time for me.

  5. #5
    . AntonLargiader's Avatar
    Join Date
    Jul 2004
    Location
    Charlottesville, VA
    Posts
    1,377
    Oops, I think I got it wrong. If it's the new style switch it is NC and opens by being pushed in (everywhere except neutral). The second washer isn't for that issue because obviously it would need to be pushed in more in your case.

    The older switch (used up to '76) was NO and was closed by being pushed in at neutral. That sometimes needed the double washer because it was being pushed in too much of the time.

    Pics on my website roughly in the middle of this page:

    http://www.largiader.com/tech/airtrans/

    But your bike should have the newer switch. So if there's a second washer, get rid of it. If there's only one, I'd just buy a new switch and washer. And if the light stays on when you unplug the switch, it's a problem in the wiring.
    Anton Largiader 72724
    largiader.com bmwra.org

  6. #6
    rbleau
    Guest

    Unplugged

    I unplugged the connector located near the left footpeg and the neutral light remained on.

    So, the circuit should be "open" now. If the normal action of the neutral switch sensor is to supply a closed circuit in order to illuminate the neutral light, then indeed I have a pinch or short somewhere.

    Or vice versa.

    Attached Images Attached Images

  7. #7
    Rally Rat
    Join Date
    Sep 2007
    Posts
    1,248
    Is the neutral light really on, or is the gasket inside the instrument missing, allowing the other lights to bleed over? Does it start in gear without pulling the clutch lever?

  8. #8
    rbleau
    Guest

    Short two-wire harness

    Mine has a short, less than 1 ft, little two-wire harness encased in black protective plastic or rubber; one end is to the two electrical push on connectors on the neutral sensor on the bottom of the trans; the other end has a rectangular connector that plugs into the larger harness on the lower frame rails. The oil pressure sensor wire is entirely separate. Or so it would appear - I just went out and crawled under the two wheeled vehicle again.

    I am inferring from Anton's web writeup that regardless of either switch style, a switch continuity closure is made when the trans is in neutral. Here is the web page comment:

    In 1976 the neutral switch was changed. Up through 1975 the switch was pushed in to make the neutral contact, and starting in 1976 the switch extended to make contact.

  9. #9
    rbleau
    Guest

    Back to this task - 1977 R100S

    OK, after a break, I started troubleshooting again. Turns out that the clutch safety interlock plunger switch was coiled and stuffed above the engine. Interestingly, when I depressed the plunger, simulating clutch engaged, the neutral light went out, and I doubt the clutch switch should interact with the neutral light (?), per wiring diagram. There is a diode between each side of 85b in the schematic. Inside the headlight looks normal - two brn/yel on 85b, then to the left (right side of headlight) one brn/blk wire.

    Also interesting - good thing I had not hit the starter button in gear with clutch engaged - could have been exciting.

    Always intersted in any suggestions of where to look next. Looks like the prev owner was messing around a bit, eh ? This is a bike I bought in January.
    Attached Images Attached Images
    Last edited by rbleau; 04-26-2009 at 02:28 AM.

  10. #10
    Rally Rat
    Join Date
    Sep 2007
    Posts
    1,248
    It sounds like you have the "classic" shorted neutral/clutch switch diode. This diode is on the back side of the cicuit board in the headlight. An easy fix is to remove the associated wires from the board and connect them with the diode from a hazard warning (4-way flashers) light kit. A harder but more elegant solution is to remove the board and solder in a new diode.

  11. #11
    rbleau
    Guest

    Thumbs up Resolution and Closure

    OK, well here is the deal. The prev owner, either by himself or maybe not, had replaced the transmission neutral switch with the incorrect or "backwards" switch, then had disabled the clutch interlock as a means of starting in actual neutral. The transmission has been pulled, switch replaced and verified, and while in there, R&R rear main seal, replaced clutch diaphragm spring, oil pump seal, spline lube & cleanup. Bike all back togetehr and neutral light works as it is supposed to. I assisted/ performed tasks that did not require special skills or tools, but the serious work was done by a professional. End of story.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •