Search:

Type: Posts; User: PETDOC; Keyword(s):

Page 1 of 18 1 2 3 4

Search: Search took 0.08 seconds.

  1. Replies
    15
    Views
    1,209

    I've got an '04 1150 GS that developed the flash...

    I've got an '04 1150 GS that developed the flash pattern indicative of a bad brake light bulb. Pulled the bulb and it appeared fine. Flashing went away for about a week, then returned. I pulled the...
  2. Need a link to Mark McMahon, Custom ear plug maker

    At the 2011 MOA Rally I listened to Mark MaMahon give a talk titled "the silent killer". He makes custom ear plugs. Can anyone give me a link to his web site?
    Thanks
  3. Replies
    10
    Views
    875

    I've got an '04 1150 GS and as I recall the...

    I've got an '04 1150 GS and as I recall the factory recommendations on the brake fluid change is every year on the wheel circuits and every 2 years on the control circuit, unless you have stainless...
  4. Replies
    32
    Views
    1,458

    I totally agree. My Front Ohlins began leaking...

    I totally agree. My Front Ohlins began leaking oil at 20,000 miles. Sent them in for a rebuild and the ride was appreciably better than before the rebuild. Really good shocks don't last any longer...
  5. Replies
    32
    Views
    1,458

    Couldn't have been said better! I replaced my...

    Couldn't have been said better! I replaced my stock shocks with Ohlins around 20,000 miles. Not because I thought my stock shocks were bad, but because I wanted a pair of Ohlins. WOW! The difference...
  6. Replies
    11
    Views
    995

    Had a similar, but not as harrowing an experience...

    Had a similar, but not as harrowing an experience on my '04 GS. I crested a hill on a very wet 2 lane road with a center turn lane. My view field was immediately filled by the broadside of a school...
  7. Replies
    29
    Views
    2,649

    Since new my '04 GS pinged on acceleration...

    Since new my '04 GS pinged on acceleration during really hot weather (ie, >90 degrees), especially when going up a hill. Nothing I did seemed to help until I upgraded the left side cam chain...
  8. Thread: No start

    by PETDOC
    Replies
    6
    Views
    564

    My guess is either loose battery connection or...

    My guess is either loose battery connection or bad starter.
  9. Thread: Clutch slipping

    by PETDOC
    Replies
    3
    Views
    428

    I've got an '04 GS that had a slave cylinder...

    I've got an '04 GS that had a slave cylinder fail. I replaced the slave cylinder, but did not replace the rear input seal, which sits immediately in front of slave. Shortly thereafter my clutch began...
  10. Replies
    26
    Views
    2,544

    My '04 GS at 17,000 miles began having...

    My '04 GS at 17,000 miles began having intermittent starting issues characterized by not turning over and zeroing out the clock on the first try, but usually by the 2nd or 3rd try starting. This...
  11. Replies
    40
    Views
    12,444

    ModuleMaster now rebuilds the BMW ABS pumps for...

    ModuleMaster now rebuilds the BMW ABS pumps for most models and gives a better guarantee than BMW when new. http://advrider.com/forums/showthread.php?t=852577. I do not believe they can yet source...
  12. Replies
    14
    Views
    1,627

    I've replaced my slave cylinder twice and I...

    I've replaced my slave cylinder twice and I recall that there was some pressure exerted by the pushrod against the slave cylinder bearing as I pushed the cylinder all the way into the cavity in the...
  13. Replies
    7
    Views
    977

    On my '04 1150 GS the brake warning light came on...

    On my '04 1150 GS the brake warning light came on and I looked at both the rear light and bulb-everything appeared fine. The warning light went off for a brief time then re-illuminated. The second...
  14. Thread: Occams Razor

    by PETDOC
    Replies
    3
    Views
    807

    I've experienced a couple of those when I rode my...

    I've experienced a couple of those when I rode my R80/7. I put a SmarTire Pressure monitor on my '04 GS. I appreciate the early warning it provides and the fact it negates the chore of routinely...
  15. I elected to go with the "no lubricant" option....

    I elected to go with the "no lubricant" option. The tank was resting on its right side and the O ring sat securely in the groove. The torque recommendation I found for the 6 nuts that hold the plate...
  16. Rubber O ring for Fuel pump/filter plate--lubricate??

    I replaced the fuel filter on my 1150 GS and looked in 3 resources to see if I should lubricate the new rubber O ring for the fuel pump/filter plate. 1, Haynes says to use a light coat of gasket...
  17. Replies
    13
    Views
    1,513

    I'll be the second to second that statement....

    I'll be the second to second that statement. Installed mine years ago, no issues. To get my torque wrench in below the attachment of the telelever I bought a cheap socket and ground it down until it...
  18. Thread: RT or GS

    by PETDOC
    Replies
    35
    Views
    3,740

    I've got an'04 1150 GS and have not ridden an RT...

    I've got an'04 1150 GS and have not ridden an RT yet; therefore, my response may or my not be of much help. I'm 63 with a 32" inseam and have ridden my GS 50,000 miles mostly on long cross country...
  19. Replies
    28
    Views
    1,892

    Alex, I'm curious as to what battery you use?...

    Alex,
    I'm curious as to what battery you use? Your statement would rule out both AGM and gel batteries. That only leaves a conventional flooded lead-acid battery or a lithium battery.
  20. Replies
    28
    Views
    1,892

    When I had a similar problem due to my starter my...

    When I had a similar problem due to my starter my GS would crank fine most of the time, then out of the blue it would not turn over and the clock would zero out. When I'd try to re-start it typically...
  21. Replies
    28
    Views
    1,892

    I've had that happen from 2 different causes on...

    I've had that happen from 2 different causes on my '04 GS--weak battery and bad starter. Might check/clean the connections to the battery.
  22. Replies
    9
    Views
    723

    Do you consider the mid to low 30's the "dead of...

    Do you consider the mid to low 30's the "dead of winter?" If not a lithium battery may not be for you.
  23. Replies
    6
    Views
    650

    I concur. It is a royal PITA to tear your bike...

    I concur. It is a royal PITA to tear your bike apart for a clutch job. Why risk having to do it all over again in short order. I'd recommend replacing the clutch slave cylinder and rear input seal at...
  24. Thread: Seafoam??

    by PETDOC
    Replies
    62
    Views
    6,524

    Please post the results. I'm right at 50,000...

    Please post the results. I'm right at 50,000 miles and have routinely used Techron Fuel System Cleaner.
  25. Thread: Seafoam??

    by PETDOC
    Replies
    62
    Views
    6,524

    I did the SeaFoam "treatment" (i.e., gas tank,...

    I did the SeaFoam "treatment" (i.e., gas tank, crank case and aspirated into throttle body) on my '88 4Runner which had ~300,000 miles on the odometer. The results were nothing short of amazing--oil...
Results 1 to 25 of 431
Page 1 of 18 1 2 3 4