Search:

Type: Posts; User: mgalie; Keyword(s):

Page 1 of 2 1 2

Search: Search took 0.05 seconds.

  1. Replies
    16
    Views
    1,509

    +1

    +1
  2. Thread: Overheating?

    by mgalie
    Replies
    10
    Views
    995

    I put in a little less than half a liter of AF...

    I put in a little less than half a liter of AF mix last night and that did the trick. Feeling pretty stupid for not reading the directions: i.e. checking the level while the bike's hot. :doh On...
  3. Thread: Overheating?

    by mgalie
    Replies
    10
    Views
    995

    I changed all of the fluids last month and the...

    I changed all of the fluids last month and the radiator looked as clean as a whistle... The thermostat has also been recently replaced and all the hoses feel pressurized when the bike is hot. Even...
  4. Thread: Overheating?

    by mgalie
    Replies
    10
    Views
    995

    Sorry about the limited info, guys. This...

    Sorry about the limited info, guys.

    This morning I checked all of the hose clamps and let the bike idle until the temp light came on. It took about 12 minutes for the light to come on in the 80...
  5. Thread: Overheating?

    by mgalie
    Replies
    10
    Views
    995

    Overheating?

    After the bike has warmed up, the temp light on my K75 comes on and stays on, even at speed. Is this a faulty temp sensor, or can the bike actually be overheating at 40+ mph?
    Over the past year...
  6. Replies
    10
    Views
    947

    Yes, thanks for the advice: I've been haunting...

    Yes, thanks for the advice: I've been haunting this list long enough to know that Don's hunches are pretty reliable. I only had enough time today to tug on the starter connection: it was tight. ...
  7. Replies
    10
    Views
    947

    Update

    The other night the lights went into fail mode again, but came back on before I could get anything done! After getting the bike back together, another issued cropped up: the fuel pump isn't getting...
  8. Replies
    10
    Views
    947

    Smacks self in head with test light

    :doh Thanks, Don. You're absolutely right; I DID test it while it was working and it most definitely is an intermittent. Funny how all your (my) sense gets washed away by spring time and...
  9. Replies
    10
    Views
    947

    Electrical Gremlins!

    This is an intermittent problem the bike (an 87 K75s 46k) has been having for the past two months. Occasionally the lights will go out; that is, headlight, rear running light, instrument lights. ...
  10. Replies
    15
    Views
    1,400

    Ahh, great information! So I guess the bars I...

    Ahh, great information! So I guess the bars I sold really are not "true" C-bars. ...Annoying, but good to know. So if anyone wants to buy a set of T-bars....... *chuckle chuckle*

    But I'm still...
  11. Replies
    15
    Views
    1,400

    Model/Handlebar Question

    For all of you K75 model historians...

    I recently resold a set of handlebars that I believed to be C-bars. My only reason for believing they are C-bars is because I was told that is what they...
  12. Thread: Transmission

    by mgalie
    Replies
    6
    Views
    934

    Flaky Speedo

    Look under the K-tech section at www.ibmwr.org for detailed info on how to fix the speedo; it's probably just a corroded electrical connection. Mine goes out intermittently now - haven't had time...
  13. Thread: Buzz and Shake

    by mgalie
    Replies
    3
    Views
    803

    Took the bike to the local dealer today. Didn't...

    Took the bike to the local dealer today. Didn't get to ride another K, but the head tech (the only one, really) looked at it and was not perturbed. He wrote it off to the new transmission: will...
  14. Thread: Buzz and Shake

    by mgalie
    Replies
    3
    Views
    803

    Thanks Don. I marked all the clutch stuff...

    Thanks Don.

    I marked all the clutch stuff myself: no factory marks. I took extra care to mark and realign them, so I hope that's not it.

    Now to find a K.... Maybe the dealership up the...
  15. Thread: Buzz and Shake

    by mgalie
    Replies
    3
    Views
    803

    Buzz and Shake

    1987 K75s with 34000k.

    The problem, or is it?: Shaking/buzz kind of thing at low revs 1500-2500 rpm with either the clutch in or out. It's not very strong; I don't feel it in the handle bars,...
  16. Replies
    6
    Views
    1,044

    Yeah, the bits about the headlight sounds like a...

    Yeah, the bits about the headlight sounds like a dirty starter. But the fact that it doesn't crank at all sometimes makes me think it could be something else. I'd check the starter first, though.
    ...
  17. Thread: Huh??

    by mgalie
    Replies
    14
    Views
    1,143

    Will do! I compared the new cable to the old...

    Will do!

    I compared the new cable to the old one, and the old one does appear to be longer. Will have to pull the old one tight, though, to find out.
  18. Thread: Huh??

    by mgalie
    Replies
    14
    Views
    1,143

    The brick flies again!

    Well, all is in order with the new clutch cable! Have been out putting around the past two days. I still have some lingering concern about just what happened to the old cable (it's not obviously...
  19. Replies
    10
    Views
    1,237

    Word

    Just had a clutch cable problem, myself. At the dealer, I bought two more cables but no spare nipple. Looks like I'll be going back....
  20. Thread: Huh??

    by mgalie
    Replies
    14
    Views
    1,143

    The metal ring is in place. It's hard to...

    The metal ring is in place.

    It's hard to describe how the lever feels from memory. I'll have to get back to you on that when I'm near the bike.

    I guess it's off to the dealer tomorrow for a...
  21. Thread: Huh??

    by mgalie
    Replies
    14
    Views
    1,143

    Indeed, the wire ring is in there. The issue...

    Indeed, the wire ring is in there.

    The issue I'm having is strictly with the cable, though (so it seems to me). The swing arm is at the furthest point it could be, and there is just way too much...
  22. Thread: Huh??

    by mgalie
    Replies
    14
    Views
    1,143

    Right about the shoulder at the clutch end; the...

    Right about the shoulder at the clutch end; the new trans didn't have this, so it must have been from a K100.

    As to #14, on the K75 at least, it is a separate piece. To get the push rod out of...
  23. Thread: Huh??

    by mgalie
    Replies
    14
    Views
    1,143

    You're right, the K75 push rods come out of from...

    You're right, the K75 push rods come out of from the engine side. The new tranny had a different style rod, so I swapped it along with the ball bearings, pressure piston and bush (PN 14) from the...
  24. Replies
    11
    Views
    918

    Some good info here under the "Starter" section...

    Some good info here under the "Starter" section (scroll down a bit).

    http://www.ibmwr.org/ktech.shtml

    Mebe it just needs cleaned?
  25. Thread: Huh??

    by mgalie
    Replies
    14
    Views
    1,143

    No, just checked; it's definitely seated. The...

    No, just checked; it's definitely seated. The cable just has waaay too much slack (even with the swing arm resting on the muffler) and there isn't much room left on the adjuster up by the grips.
    ...
Results 1 to 25 of 38
Page 1 of 2 1 2