PDA

View Full Version : K100RS hiccup



Steve
08-14-2003, 04:16 PM
My 59000 mile 1991 16 valve K100RS has developed an annoying little hiccup at low rpm. Or, more specifically at low throttle openings as it happens with the "choke" on when I start up and when I'm stuck in traffic and running about 2500rpm. Its audible, something like a small pnuematic solenoid going off and I can feel it throughout the bike, just little glitch. Seems to be getting worse/ more frequent as the summer goes on. Have not had any trouble at road speeds (anything above 3000rpm is clear). I know, "Just keep the revs up" well, as a commuter/daily rider I don't have the luxury of always howling around the back country....

I'm thinking either the TPS or the system that shuts off fuel flow when you back off the throttle is the culprit here. Anybody out there want to take a crack at this one?

=========================================
The TPS should be out of circuit at that RPM, but to test it you can simply disconnect it. It won't effect it running, it just won't cut the fuel on fully closed throttle, or add fuel on full open throttle.

Lots of other things to think about:

1. 1st rule of K bike troubleshooting - replace the fuel filter.

2. Cleaning all the electrical connectors, and perhaps cleaning the ignition switch (see IBMWR tech pages for details)

3. R&R the starter - and clean the inside (details on IBMWR K-tech pages) - it can cause all sorts of odd symptoms when it gets carboned up inside.

4. Disconnect and reconnect the brain - the contacts need working once in a while to make good contact. This is called "laying on of hands"

And lots more - without being there to experience it, it's hard to diagnose from a distance.

HTH,