PDA

View Full Version : K75 - Won't Start - Any Ideas



Tom
05-22-2003, 08:34 PM
Out of winter storage and won't kick over, here's what I know:

Cranks
Had a couple of backfires
Replaced plugs
Got good crisp spark on plugs
Gas to plugs OK
Battery charged
Tried to push start with no luck

Wanted to buy diagonstic for checking ignition timing but local dealer won't sell, not sure where to go for that.

Any ideas.......................

jdiaz
05-22-2003, 08:47 PM
Sounds like it might be flooded. Leave the spark plugs out overnight to dry the cylinders and the spark plugs, and try it again in the am.

One other thing: did you remove the fuel injection computer to check the battery for any reason over the winter? If that big connector isn't fully seated/snapped into the computer, the bike definitely won't start at all.

basketcase
05-23-2003, 11:47 AM
The kill switch on the handlebars? It'll get'cha every time.

And don't worry about how I know to check that ...

K75LT
06-04-2003, 03:55 PM
always get back to basics!

air / fuel
spark
battery- computer

take a spare plug and connect it, crank it, to confirm spark
cant hurt to check plug gap
maybe check fuel filter not enough gas? or crud in filter
eliminate one thing at a time

if you have to push start it cause the battery is to low you dont have enough power for the computer

good luck

JERRY
06-04-2003, 06:56 PM
TRY REPLACING THE PLUGS AGAIN.
HAD THIS PROBLEM A FEW YEARS AGO.
HAD SOMEHOW DAMAGED A PLUG ON REPLACING. TOOK ME TOO LONG TO GET BACK TO PLUGS.