PDA

View Full Version : Battery OK ?



jimfastcar
03-18-2009, 01:21 AM
Question for the electrical wizards.

Plug in BMW battery tender every time I park the bike as there may be 2 or more days between rides. I have it hooked directly to battery to bypass complications of CanBus.
At first for an hour or so, just the red light, then flashing green for a few hours, then solid green, which suggests (to me anyway) that battery is now fully charged.
If the alternator is working correctly, and the battery is in good shape, should it not be fully charged when I turn the bike off ? Is this a sign of a imminent need for a new battery, or am I just imagining things ??

PGlaves
03-18-2009, 03:31 AM
Battery is probably OK. And you have, all by yourself, answered that age old challenging question about chargers designed specifically for gel cell (and some AGM) batteries. "Why do I need a special charger for this special battery? They didn't change the alternator!" The answer of course is - the alternator doesn't necessarily fully charge the battery! Close - but not fully! Maybe they should change the alternator.

stkmkt1
03-18-2009, 04:11 AM
I agree with the above post. I have two bikes, both with brand new batteries. The neer bike, '09, has a much larger alternator and thus when I plug in the battery tender, it takes it only a little while before the green light is on. The older bike, '77, has a very small alternator and thus does not come even close to charging the battery. So it takes quite a while to get a green light.