PDA

View Full Version : R1200RT Cruise control failure



dockeithdc
02-16-2009, 12:41 PM
Has anyone experienced any problems with there oem cruise control? I have an 08 RT that I ride year round but yesterday when I attempted to engage the cruise it would not set.

A few weeks ago I had noticed a burning smell, but that occured after a good cleaning and I assumed that it was just the cleaning agents burning of the pipes...

Any suggestions?

MLS2GO
02-16-2009, 02:30 PM
That's the best I can give you. I asume it is under warranty still?

lensuz
02-16-2009, 03:46 PM
Are you sure you're not "riding" the rear brake?

sailorlite
02-16-2009, 03:55 PM
My cruise control failed at about 3K miles - wouldn't take a set. Dealer replaced the handlebar switch assembly under warranty and all's now OK. Warranty's good because that switch is quite expensive.

dockeithdc
02-16-2009, 04:56 PM
I think you are on to something. Today I noticed the little red light in the switch is not on. Sounds like it may be the switch. Thanks for the input.

Semper_Fi
02-16-2009, 06:15 PM
One thing that happend to me is that i used the connector for the oem GPS to trigger my Centech relay.

The actual issue was that there are 3 wires on that connector - hot/ground/dead reconning.

The dead reconning is only used by the BMW GPS - anyway i inadvertently tied the ground and the DR signal together.

Everything ran fine but no cruise - once disconnected it ran fine.

If not this, I would take it to the dealer.

dockeithdc
02-16-2009, 06:54 PM
interestingly, on my way home today I tried the cruise and suprisingly the little red light came on and I was able to set the cruise. That worked a couple of times and then the light on the switch did not come on. No cruise again... At this point I would assume it is the handlebar switch.

Semper_Fi
02-16-2009, 11:30 PM
If its under warranty - see your dealer.

The switches are not very user servicable

108281
02-19-2009, 09:39 PM
I had a problem with my '05 also. It would set okay and hitting the brake would turn it off but backing off the throttle wouldn't, in fact it wouldn't let me back off the throttle. To turn it off I had to hit the brake. The dealer replaced the switch and it was fine. It apparently isn't an easy job as the service manager had me wait until one particular mechanic was free as he said he was the only one familar with it.