PDA

View Full Version : 1991 K75RT no gauges



acehosedme
06-18-2004, 10:42 PM
I just picked up a 1991 k75rt with low miles, at least the odometer reads low. The following do not work: speedometer, odometer, fuel indicator lamp, choke lamp and the turn signals do not cancel until I do it manually. I unplugged and cleaned (not that it looked at all dirty)the terminals of the 2-wire connector on the right side of the bike under the side cover. I removed and looked at what the speedometer inductive transmitter on the top of the fianl drive, it looked cleaner than the one on my 1987 k75t. There is supposed to be a film of lubricant of sorts there right?
What do I look for next? Do i start removing the fairing to get to the instrument cluster or is there something else I should look at first? Is htere an easy way to get the instrument cluster out without having to remove the fuel tank and fairing?

Thanks, Bob

90288
06-19-2004, 01:51 PM
Ah yes. The non working instrument cluster on your K bike is the official WELCOME to the world of K bikes.

Really a great bike but the instrument cluster is the only piece of junk on otherwise a spectacular bike.

I have a K100RT with a cluster that does all sorts of weird things. Personally, I think the cluster on my bike is possessed. I'm just about ready to throw it away and go to a GPS unit.

What happens is the early K models allow moisture inside the unit and that eventually works it's way into the circuit boards.

Anyhoo, what you have is one of the crappy clusters which no amount of "fixing" will cure. Sorry about that news but you may as well know now. You either have a good cluster or a bad one and there doesn't seem to be any middle ground.

If you are so inclined to try and screw around with it, here's a link which may help.

http://www.ibmwr.org/ktech.shtmlhttp://www.ibmwr.org/ktech.shtml

If you want to take the cluster off, remove the windshield only. This will give you access to the 2 Allen screws which hold it to the steering head. You don't have to take the fairing off. I should know, I have done it enough times.

Good luck!

volkmare
06-19-2004, 07:52 PM
I agree, and then disagree with the first response.

The K-bike instruments have one fatal flaw. They used tin plated contacts on all connectors.

BUT!

there is a solution. It's called Stabalant22. It is a block ploymer that will conduct in tight places like between the pins of a contact, and will not evaproate.

My 85 K100rs developed problems after about 30k miles. If i went in and wiggled the connections, it would help for a brief while, but would return to normal intermittant operation very shortly.

After applying stabilant22 to all connections inside the instrument cluster, and all connectors in the wiring harness, all intermittants have gone away. Totally.

Technical data.
i also use it in my job as a clinical engineer, where electrical safety is a high priority. Power cord ground conductivity is therefore a point of focus. commonly i have found ground resistance in the 0.3 to 1.5 ohm range. after treatment with stabilant22 it lowers to less than 0.07 ohm (the resistance of the wire) and stays there, even after 2 years service.[B]

Try it, you'll like it. (Hay! MIKEY!)