PDA

View Full Version : Fuel gauge problem on 07 GSA



tuckerdt
09-30-2007, 11:55 PM
I've posted on this subject before and acted on some of the advice I received. My complaint is the fuel gauge on my 2007 R1200GS Adventure does not work like I think it was designed to work:

1. After filling up, the indicator may take several minutes to register that fuel was added. Sometimes it will indicate full, other times it might go near the top.

2. The fuel gauge has one bar at 120 miles, which remains until about 200 miles, then the low fuel indicator comes on with the yellow triangle.

3. Each time I start my bike the fuel gauge reads a different number of bars.

4. The fuel gauge has operated accurately on every bike I have ever owned, except the most expensive one.

My dealer tells me they will replace the fuel level indicator if I pay for it. Then they told me to contact BMW Motoradd directly, and when I contacted them, they told to go to my dealer as they have lots of resources at their disposal. I took the email back to the service manager at Accolade Motorsports in North Salt Lake City, Utah, and he said he'd look into it and contact me. That was over a month ago with no word.

Has anyone else had this problem, and if so, what did you do to correct it?

I am desperate for help in getting this problem solved.

Plainsscout
10-01-2007, 02:06 AM
Yep. I have the same thing on my GSA as does my buddy who has the GSA.


I just know that when it goes to one bar I still have about 140 miles even though my computer says that I have 90 and it stays that way for a long time.

I have not pushed it to the limit where the warning light comes on.

I can live with it, but it makes me nervous when the bike computer says I have 90 miles left and I can ride it that way for maybe 140 miles.

Keep us posted on what you get done to resolve this.

klrobins
10-01-2007, 10:42 AM
Likely if its the same problem as the fuel gage on the regular GS then the fuel strip will have to be replaced. There is a thread on this site about it.

klrobins
10-01-2007, 10:43 AM
see this thread

http://www.bmwmoa.org/forum/showthread.php?t=17185

SNC1923
10-01-2007, 12:30 PM
I've posted on this subject before and acted on some of the advice I received. My complaint is the fuel gauge on my 2007 R1200GS Adventure does not work like I think it was designed to work:

1. After filling up, the indicator may take several minutes to register that fuel was added. Sometimes it will indicate full, other times it might go near the top.

2. The fuel gauge has one bar at 120 miles, which remains until about 200 miles, then the low fuel indicator comes on with the yellow triangle.

3. Each time I start my bike the fuel gauge reads a different number of bars.

4. The fuel gauge has operated accurately on every bike I have ever owned, except the most expensive one.

You've described accurately the precise manner in which my fuel indicator operates. A bit disconcerting at first, but when used in combination with the trip meter, I've found it to be both regular and reliable.

Like it or don't, apparently it IS the way it was designed to operate. Sorry it's bugging you so much.

The_Veg
10-01-2007, 07:27 PM
I have a 2007 GS (NOT GSA) equipped with the computer (2063 miles on it as I write this, and a production-date of May 2007 if that's relevant to anything).

After having read the threads linked here (all the way to the ADVR thread), I can say that mine is a bit odd too:

1) When I fill up, it doesn't recognise a change in fuel-level for a moment or two- but I don't think it takes longer than 30 seconds to reflect filling, and it seems to respond more quickly the sooner the bike gets moving.

2) It usually takes about ten miles (up to fifteen in a couple of cases) after fill-up for the top-bar to come ON. I have not noted how long it takes the top bar to then go OFF again.

3) No fuel gauge I have ever used on any vehicle has been what I'd call 'linear' in the rate at which it goes down, this one included- so odd rates of drop don't bug me much. But this one doesn't do any precipitous drops like from full to half or from half to near-empty. The bottom-half of the gauge does drop more quickly, but not enough so to alarm me. BTW a quick check of the manual says that non-computer bikes have a slightly different gauge-display and that on those bikes the top-bar "is equal to approximately half the possible tank volume, and the next bar approximately one-quarter. The remaining fuel tank volume is shown in greater detail with the smaller horizontal bars."

4) I often get the 'FUEL!' warning at around 130 miles (sometimes more). But I've seen different estimated ranges appear when the warning comes on, usually 47 miles but this weekend I also saw 42.

5) If I fill up right after the warning comes on, it usually takes 3 to 3.4 gallons.

6) I have no idea how accurately the bike senses either speed or distance. I'm sure it's more accurate than an airhead though. As a result, I do not know the accuracy of the computer's average-speed or -MPG data (I do not have a GPS to use as a benchmark).

I mentioned the range-warning to a guy in my club who has worked on and off for the local dealer sometimes, and he suggested that I reset the readouts while moving, instead of while I'm still stopped at the pump. His idea is that if the bike is sensing motion when everything gets zeroed, the computer will have more accurate data with which to work. I've been doing this for a week or so and I have noticed an improvement, if not a cure.
I should mention that the type of riding I do varies a bit- some local stuff (errands, etc.) and some highway stuff. I don't think I've done more than two-and-a-half consecutive tanks of highway in a single trip yet.
Saturday I rode 386 miles (from Frisco ('burb of Dallas, not San Francisco) to Nacodoches and back), about 95% (guessing) of which was highway. While I didn't pay much attention to the numbers on the way out, on the return-trip I did. I had refueled a few miles before my destination, so I had a nearly-full tank on the way back. I got the warning at about 140 miles, indicating 42 to go. Now if this means 42 *before* hitting that last gallon (and the manual implies that this is the case), then I am happy with the numbers, especially since my cruise-speed was usually over 70. I have noticed with this bike that MPG takes a noticeable decline when I get into the higher-end of plausible highway-speeds. And yes, I have noticed the sensitivity to throttle-input too- if I really exercise a lot of restraint, I can get indicated-MPG's in the mid-40s, but I can also be a hooligan and knock almost ten percent off that (damn this thing accelerates!). This bike is so much fun to ride that it is often very difficult to maintain best-efficiency. :D

So do I have an actual problem with range-indications? It's possible, but I'm not convinced. The more I observe and get to know the bike the less of a problem it seems to be.

klrobins
10-02-2007, 10:45 AM
We were told by the dealership that BMW Canada said there would be NO general recall, and that they were only to address the bikes of people who complained about the problem.

For hubbys bike the first thing they did is completely empty the fuel tank, let it completely dry out over two days (dry the fuel strip), then reset the computer and refill the tank. This seemed to solve the problem for the first two or three fills, but after that it went back to completely unpredictable. Thats when they agreed to replace the fuel strip.

The advantage for us is that he has the GS with the computer and I have the GS without it, so we were able to do direct comparisons on how the fuel gage worked. His "Range" would be 0 after about 200-250km and my fuel light wouldnt even be on!! There was definitely a problem there.

tuckerdt
10-02-2007, 09:11 PM
see this thread

http://www.bmwmoa.org/forum/showthread.php?t=17185

Thanks for the thread Kristi with the national BMW number.

I called the 1-800-831-1117 number for the national BMW helpline and spoke with Tony. I took a bit of time describing the problem with the fuel gauge, and hence the computer. He asked me a few questions for clarification, then mentioned that this situation would be unacceptable to him.

He said BMW was aware of this problem and that materials had been mailed to all dealers regarding this problem. He told me he would contact my dealer to make sure they were aware of my problem (my dealer is very aware of my problem to the point I can watch their smiles fade when they catch sight of me walking into the service department).

OK so far, but here's the real shocker:

Tony called me back in less than 5 minutes, saying that he had spoken with the Service Manager of the dealership where I purchased my bike, and that he had received the materials from BMW and I was on his list to call. So, now I am waiting to hear from my local dealer.

Maybe I'm naive, but this is more action than I've seen since Dec. 2006.

My advice: if you have a similar problem and have not had success solving it with your local dealer, call the number above.

Tucker

tuckerdt
10-02-2007, 09:42 PM
You've described accurately the precise manner in which my fuel indicator operates. A bit disconcerting at first, but when used in combination with the trip meter, I've found it to be both regular and reliable.

Like it or don't, apparently it IS the way it was designed to operate. Sorry it's bugging you so much.


I've been dealing with this situation for over 16.5k miles since Nov, so obviously I can live with it. But I don't accept that this is the way the BMW engineers designed it, and that's why I've continued to pursue it.

I purchased this bike to ride out in areas far away from paved roads, gas stations, cell phone signals, etc. The reasons I would like the fuel gauge to reflect what I have left in the tank are twofold:

1. My fuel mileage is not constant, so using my trip odometer could be misleading. I calculate my mpg when getting fuel so I know what I'm getting. Wind, load wgt, elevation, speed, whether my panniers are attached... all greatly affect my mpg.

2. What if: I rode 100 miles after fueling up, my gauge is down to 2 bars like usual, then I develop a leak in my fuel line or tank? With a properly functioning gauge I would soon know I had a serious problem. With my current gauge, I would have no idea until it was too late.

If BMW makes my gauge work like I think it should, I'll be thrilled. In any case, I will share my results here.

burnszilla
10-02-2007, 10:09 PM
My GS is going in tomorrow for its 3rd fuel strip replacement. We'll see what happens.
Untrue rear wheel is getting replaced under warranty too.

kbasa
10-02-2007, 10:31 PM
Thanks for the thread Kristi with the national BMW number.

I called the 1-800-831-1117 number for the national BMW helpline and spoke with Tony. I took a bit of time describing the problem with the fuel gauge, and hence the computer. He asked me a few questions for clarification, then mentioned that this situation would be unacceptable to him.

He said BMW was aware of this problem and that materials had been mailed to all dealers regarding this problem. He told me he would contact my dealer to make sure they were aware of my problem (my dealer is very aware of my problem to the point I can watch their smiles fade when they catch sight of me walking into the service department).

OK so far, but here's the real shocker:

Tony called me back in less than 5 minutes, saying that he had spoken with the Service Manager of the dealership where I purchased my bike, and that he had received the materials from BMW and I was on his list to call. So, now I am waiting to hear from my local dealer.

Maybe I'm naive, but this is more action than I've seen since Dec. 2006.

My advice: if you have a similar problem and have not had success solving it with your local dealer, call the number above.

Tucker

I was going to comment that your local dealer doesn't seem to be doing you any favors on this, but it looks like that's pretty evident to you.

tuckerdt
10-04-2007, 04:00 PM
Yesterday, I received a call from the Service Department of my local BMW dealer. He did mention they had received a call from the national service office to advise them of my problem (not aware after my 4 visits, but suddenly aware after a call from national..... interesting).

The guy told me he was sorry I was having problems with my fuel gauge and that they had recently received a software upgrade that hopefully would solve this malfunction and was anxious to schedule me in.

OK. Even if the software patch doesn't fix the problem, at least now both the national and local BMW people are acknowledging that the gauge is not operating as intended. I have an appointment and will be back with the results..... after several tanks of fuel.

mtfrench
10-04-2007, 04:47 PM
This is exactly the suggested fix I was told by the mechanic at my local dealer when I complained about the problem on my 07 GSA a few days ago. Because I have to leave the bike with them for a few days to implement this fix under warranty, I'm going to wait a few weeks and hope that BMW comes out with a better computer upgrade as well. I'll be watching this thread closely to see how others resolve the problem so keep the info flowing.

By the way, I was riding around town with easy access to gas stations this weekend and decided to do an experiment when the gas got low. The yellow warning light came on when the range dropped to 46 miles, as it should with about 1 gallon left in the tank. I continued riding until the range read 15 miles and decided not to push my luck. I pulled into a gas station and filled up the tank with 8.4 gallons. With a stated capacity of 8.7 gallons, this is exactly what I would expect with 15 miles reading on the computer. Does this mean that the fuel gauge is unreliable until it reaches the reserve amount?:banghead

Additional complexities to ponder....

meisco
10-08-2007, 02:47 AM
I concur with mtfrench. It seems odd to have the fuel guage start to report correctly only when it hits the last gallon or so. Mine does the same thing . . . even after a fuel strip replacement.

So . . . . . is this another 'they are supposed the do that' solution from BMW?

I complained about mine at the 6K service, and the dealer did a 'recalibration'. It didn't fix it. I complained again at 12K, and they did replace the faulty strip. Now it's acting up again. Aaargh! Like tuckertd says - every other gas guage has worked, except on the most expensive bike I've every owned.

Btw, at the 6K service (9 months ago) I mentioned this forum discussion, and they went bonkers. Seems they don't like people talking among themselves or sharing info with each other. What gives?

JK
10-08-2007, 03:41 AM
With all the ongoing headaches and hassles, I fully understand why BMW didn't include a gas gage on my '07 R-12s. It only has a blinking "dummy" light when it hits reserve.

J.K. :scratch

tuckerdt
10-09-2007, 02:19 PM
This forum is the way I find out if my problem is unique, or is it shared by many others with the same model bike. The service department of my dealer also got a little upset when I mentioned lots of others with 07 GSAs had a similar problem. But it seemed to get results. But the even bigger stimulus was when I called the national BMW 800 service number!

What did people do before personal computers?





Btw, at the 6K service (9 months ago) I mentioned this forum discussion, and they went bonkers. Seems they don't like people talking among themselves or sharing info with each other. What gives?

meisco
10-09-2007, 07:40 PM
Just an update . . . . last night I filled the tank with 8.725 gallons. The trip odo read 360miles, the fuel guage was at the last bar, the fuel light had been on for about 10 miles and the computer read 39 miles left.

Which one do you believe?!?!?

Aaaargh!

burnszilla
10-09-2007, 08:23 PM
My new strip is not perfect. When I filled it up after the service it read 203 miles range.. Not bad. The second tank after fill up read 154 miles range. :banghead
Overall the new strip is working fine. The top half is ok.. The bottom half of gas level calculation is all wrong.
I'm also wondering if ethanol is messing with the strip.

tuckerdt
10-10-2007, 02:10 AM
My BMW Dealer software fix has had absolutely no effect whatsoever on my fuel gauge and computer. I filled the tank, but the gas gauge never went beyond 7 bars; the bottom bar is thicker and I assume it is the reserve tank, then there are 8 thinner bars above at full tank. Sometimes my gauge reads full after fueling, other times it is 1-2 thin bar short.

I rode 160 miles at 80-85 mph, at which time I had two bars left on my gauge.... one thick and one thin. My computer listed my range at 72 miles. When I filled up, the tank took 4.7 gallons.... so there were 4.0 gallons remaining in the tank. This is exactly the way the gauge and computer worked prior to the 'fix'.

Back to the 800 national service number again. I plan to tell them if they can't fix my computer/fuel gauge than I want a $275 refund..... the price of the computer.

I find it incredibly ironic that my fuel gauge has worked on 20+ bikes in my lifetime except the most expensive, incredibly engineered BMW.



Yesterday, I received a call from the Service Department of my local BMW dealer. He did mention they had received a call from the national service office to advise them of my problem (not aware after my 4 visits, but suddenly aware after a call from national..... interesting).

The guy told me he was sorry I was having problems with my fuel gauge and that they had recently received a software upgrade that hopefully would solve this malfunction and was anxious to schedule me in.

OK. Even if the software patch doesn't fix the problem, at least now both the national and local BMW people are acknowledging that the gauge is not operating as intended. I have an appointment and will be back with the results..... after several tanks of fuel.

tuckerdt
10-16-2007, 03:20 PM
After the 'software upgrade' it did not seem like there was any difference in my fuel gauge function on my existing tank of fuel.

But after the 2nd tank of fuel, things were a little different. This time my fuel gauge went all the way to the top. I rode 269 miles and the gauge has just dropped from one thick bar (reserve) and one thin bar to just one thick bar. The tank took 6.3 gallons, which is 42.7 mpg..... the computer calculated 42.? mpg. The computer gave the range as 100 miles. With a calculated 2.4 gals remaining, at 42.7 mpg... my calculated range was 102 miles. Definitely an improvement.

I'm anxious to see what this 3rd tank will show. If the performance remains the same, I will be more satisfied than previously.

ch2ous
03-11-2008, 12:54 AM
Oh Dear... I've got 120 miles on my '07 (total of 1400 ) and the gas gage is totally whacked as mentioned in all the previous posts. It went for an early spring roll on Sunday with a full tank and did maybe 80 miles and the gage reported 2 bars. I was confused :confused: I was also freezing half to death :uhoh So I pulled into a gas station thinking... holy crap... I might not make it home but it only took 2 gallons of fuel after triple clicking :huh
There are other mysteries that are surfacing with this lovely bike but this one ??:scratch I am planning to call the dealer tomorrow. Is there any hope that i might have a care free summer of enjoyment on what is really a brand new bike of such $calibre$? :german

tuckerdt
03-11-2008, 02:20 AM
My dealer did an update to my computer and that helped a little.... but only a little. What I've found is that my Range readout on the computer is pretty accurate below 100 miles, so that's what I use now. I found that out by putting a gas can in my panniers, then running the fuel Range down to 20 miles. The tank took 8.2 gallons, exactly what you'd expect if the Range readout was correct.

Every cheap ass bike I've ever owned has a fuel gauge that worked.





Oh Dear... I've got 120 miles on my '07 (total of 1400 ) and the gas gage is totally whacked as mentioned in all the previous posts. It went for an early spring roll on Sunday with a full tank and did maybe 80 miles and the gage reported 2 bars. I was confused :confused: I was also freezing half to death :uhoh So I pulled into a gas station thinking... holy crap... I might not make it home but it only took 2 gallons of fuel after triple clicking :huh
There are other mysteries that are surfacing with this lovely bike but this one ??:scratch I am planning to call the dealer tomorrow. Is there any hope that i might have a care free summer of enjoyment on what is really a brand new bike of such $calibre$? :german

ch2ous
03-13-2008, 01:58 PM
Dealer is going to replace the strip for me. They suggested I do the mileage monitoring as well.

tuckerdt
03-13-2008, 02:49 PM
I don't want to be too negative here, but if you look back through this thread you will see others with this problem who have had their fuel detector strips replaced, all without solving the problem.

However, if your dealer does solve your problem, be sure to post it, along with your dealers name and phone number so I can have my service department contact theirs.

Good luck, but I would say: don't get your hopes up too high.

Tucker





Dealer is going to replace the strip for me. They suggested I do the mileage monitoring as well.

ch2ous
03-13-2008, 03:46 PM
I don't want to be too negative here, but if you look back through this thread you will see others with this problem who have had their fuel detector strips replaced, all without solving the problem.

However, if your dealer does solve your problem, be sure to post it, along with your dealers name and phone number so I can have my service department contact theirs.

Good luck, but I would say: don't get your hopes up too high.

Tucker

I am not getting my hopes up... in fact I've been through the ringer with VW of america on terrible problems with programming of their TCUs and other various issues. It seems the same with BMW and with the dealers there is certain retoric that they have to stick too. No different in the software engineering world that I work in. I'm just want to be able to start the season on the road and not in the shop. I'm still trying to figure out if my bike was serviced before it was delivered to me. Its a year old with 1400 miles. I know they generally have service intervals of 6k but I also understand that there is a time factor to consider too. But that is another subject from this one.